summaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-11-27 07:57:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-11-27 11:02:18 +0000
commitb7902a63ac30cff6562a32162ef856409bbcc455 (patch)
treea7d33a895f510c6b1fcde51caeaeae34f9b6203c /main/open-vm-tools-grsec
parentfeed29bcdc750a57b2adc065eb8ca04a98f28f08 (diff)
downloadaports-fcolista-b7902a63ac30cff6562a32162ef856409bbcc455.tar.bz2
aports-fcolista-b7902a63ac30cff6562a32162ef856409bbcc455.tar.xz
main/open-vm-tools-grsec: rebuild against 3.6.8 kernel
Diffstat (limited to 'main/open-vm-tools-grsec')
-rw-r--r--main/open-vm-tools-grsec/APKBUILD6
-rw-r--r--main/open-vm-tools-grsec/vmci_driver_c.patch34
2 files changed, 19 insertions, 21 deletions
diff --git a/main/open-vm-tools-grsec/APKBUILD b/main/open-vm-tools-grsec/APKBUILD
index 7474ea540a..e31d47248b 100644
--- a/main/open-vm-tools-grsec/APKBUILD
+++ b/main/open-vm-tools-grsec/APKBUILD
@@ -3,8 +3,8 @@
_flavor=grsec
_kpkg=linux-$_flavor
_realname=open-vm-tools
-_kver=3.6.7
-_kpkgrel=0
+_kver=3.6.8
+_kpkgrel=1
_realver=9.2.0_p799703
_ver=${_realver/_p/-}
@@ -40,6 +40,7 @@ depends="linux-${_flavor}=${_kernelver}"
makedepends="glib-dev gettext-dev linux-${_flavor}-dev=${_kernelver}"
source="http://downloads.sourceforge.net/project/open-vm-tools/open-vm-tools/stable-${_realver%.*}.x/open-vm-tools-${_ver}.tar.gz
linux-3.6-build-fix.patch
+ vmci_driver_c.patch
vmware-modules.initd
"
# constify.patch
@@ -83,4 +84,5 @@ package() {
md5sums="37341978a00a1568b898a8ce024f9da9 open-vm-tools-9.2.0-799703.tar.gz
d9ffaf628837ea6a216b96dac69705e6 linux-3.6-build-fix.patch
+16e060275e028d1edf1c5fd1a10b6a96 vmci_driver_c.patch
afba2c3487d0b12cee80eb2f04b05ba1 vmware-modules.initd"
diff --git a/main/open-vm-tools-grsec/vmci_driver_c.patch b/main/open-vm-tools-grsec/vmci_driver_c.patch
index 67faea5513..95450d13b6 100644
--- a/main/open-vm-tools-grsec/vmci_driver_c.patch
+++ b/main/open-vm-tools-grsec/vmci_driver_c.patch
@@ -1,36 +1,33 @@
-diff -Naur open-vm-tools-2011.09.23-491607-before/modules/linux/vmci/linux/driver.c open-vm-tools-2011.09.23-491607-after/modules/linux/vmci/linux/driver.c
---- open-vm-tools-2011.09.23-491607-before/modules/linux/vmci/linux/driver.c 2011-09-26 15:16:30.000000000 -0500
-+++ open-vm-tools-2011.09.23-491607-after/modules/linux/vmci/linux/driver.c 2011-10-13 15:13:19.266661488 -0500
-@@ -241,7 +241,24 @@
+--- ./modules/linux/vmci/linux/driver.c.orig
++++ ./modules/linux/vmci/linux/driver.c
+@@ -252,7 +252,21 @@
#define LinuxDriverUnlockIoctlPerFD(mutex) do {} while (0)
#endif
-static struct file_operations vmuser_fops;
-+/*
-+ * Moved file operations initialize here because of incompatibilites
-+ * with Gentoo hardened profile/hardend Linux 3.
-+ */
++/* initilaize here to make constify plugin happy */
+static struct file_operations vmuser_fops = {
-+ .owner = THIS_MODULE,
-+ .poll = LinuxDriverPoll,
++ .owner = THIS_MODULE,
++ .poll = LinuxDriverPoll,
+#ifdef HAVE_UNLOCKED_IOCTL
-+ .unlocked_ioctl = LinuxDriver_UnlockedIoctl,
++ .unlocked_ioctl = LinuxDriver_UnlockedIoctl,
+#else
-+ .ioctl = LinuxDriver_Ioctl,
++ .ioctl = LinuxDriver_Ioctl,
+#endif
+#ifdef HAVE_COMPAT_IOCTL
-+ .compat_ioctl = LinuxDriver_UnlockedIoctl,
++ .compat_ioctl = LinuxDriver_UnlockedIoctl,
+#endif
-+ .open = LinuxDriver_Open,
-+ .release = LinuxDriver_Close
++ .open = LinuxDriver_Open,
++ .release = LinuxDriver_Close
+};
/*
-@@ -378,26 +395,6 @@
+@@ -388,26 +402,6 @@
+ if (VMCI_HostInit() < VMCI_SUCCESS) {
return -ENOMEM;
}
-
+-
- /*
- * Initialize the file_operations structure. Because this code is always
- * compiled as a module, this is fine to do it here and not in a static
@@ -50,7 +47,6 @@ diff -Naur open-vm-tools-2011.09.23-491607-before/modules/linux/vmci/linux/drive
-#endif
- vmuser_fops.open = LinuxDriver_Open;
- vmuser_fops.release = LinuxDriver_Close;
--
+
sprintf(linuxState.deviceName, "vmci");
linuxState.major = 10;
- linuxState.misc.minor = MISC_DYNAMIC_MINOR;