summaryrefslogtreecommitdiffstats
path: root/main/qemu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-08 14:17:11 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-08 14:18:09 +0100
commit4537a84f977343600a95b268579a092f74c67d22 (patch)
tree3b20762ed87e3276253439f87a345e8c14d00a6d /main/qemu
parent7a411f6fa191f497187eb25fdcec7fa961d7a827 (diff)
downloadaports-fcolista-4537a84f977343600a95b268579a092f74c67d22.tar.bz2
aports-fcolista-4537a84f977343600a95b268579a092f74c67d22.tar.xz
main/qemu: split alpha, xtensa and xtensaeb subpackages
and fix librt linking
Diffstat (limited to 'main/qemu')
-rw-r--r--main/qemu/APKBUILD24
-rw-r--r--main/qemu/librt.patch11
2 files changed, 33 insertions, 2 deletions
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 6485b99680..2664807df4 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://www.nongnu.org/qemu/"
arch="all"
@@ -11,6 +11,7 @@ makedepends="zlib-dev sdl-dev alsa-lib-dev gnutls-dev ncurses-dev glib-dev
depends=
install="qemu.pre-install"
subpackages="
+$pkgname-alpha
$pkgname-arm
$pkgname-cris
$pkgname-i386
@@ -31,11 +32,14 @@ $pkgname-sh4eb
$pkgname-sparc
$pkgname-sparc64
$pkgname-x86_64
+$pkgname-xtensa
+$pkgname-xtensaeb
$pkgname-img
"
source="http://wiki.qemu.org/download/qemu-$pkgver.tar.gz
80-kvm.rules
configure-libm.patch
+ librt.patch
"
prepare() {
@@ -88,6 +92,7 @@ _subsys() {
mv "$pkgdir"/usr/bin/qemu-system-$1 "$subpkgdir"/usr/bin/
}
+alpha() { _subsys alpha; }
arm() { _subsys arm; }
cris() { _subsys cris; }
i386() { _subsys i386; }
@@ -108,6 +113,8 @@ sh4eb() { _subsys sh4eb; }
sparc() { _subsys sparc; }
sparc64() { _subsys sparc64; }
x86_64() { _subsys x86_64; }
+xtensa() { _subsys xtensa; }
+xtensaeb() { _subsys xtensaeb; }
img() {
pkgdesc="QEMU command line tool for manipulating disk images"
@@ -116,8 +123,21 @@ img() {
mv "$pkgdir"/usr/bin/qemu-img \
"$pkgdir"/usr/bin/qemu-io \
"$subpkgdir"/usr/bin/
+
+ # we exploit the fact that -img subpackage are craeted last
+ # and check that we done have new systems that belongs in
+ # subpackage
+ local _bins= _ret=0
+ for i in "$pkgdir"/usr/bin/qemu-system-*; do
+ if [ -r "$i" ]; then
+ error "Please create a subpackage for ${i##*/}"
+ _ret=1
+ fi
+ done
+ return $_err
}
md5sums="a64b36067a191451323b0d34ebb44954 qemu-1.0.tar.gz
66660f143235201249dc0648b39b86ee 80-kvm.rules
-a69fe6ff552b61606c5550cac4294abc configure-libm.patch"
+a69fe6ff552b61606c5550cac4294abc configure-libm.patch
+9f6c3143d61748eedc8cf8d0e53aee2c librt.patch"
diff --git a/main/qemu/librt.patch b/main/qemu/librt.patch
new file mode 100644
index 0000000000..d445d1b68c
--- /dev/null
+++ b/main/qemu/librt.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.target.orig
++++ ./Makefile.target
+@@ -34,7 +34,7 @@
+ STPFILES=
+
+ ifndef CONFIG_HAIKU
+-LIBS+=-lm
++LIBS+=-lm -lrt
+ endif
+
+ config-target.h: config-target.h-timestamp