summaryrefslogtreecommitdiffstats
path: root/main/qemu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-02-18 16:30:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-02-18 16:32:01 +0000
commitcbfc4f000399fb9f3d2705afe12fc4f0115c646d (patch)
tree7b1096aa2b93bd284e20275b74db6a72c46f3a84 /main/qemu
parent8a69474721a2f59396cd6830a40e0245ec968ab1 (diff)
downloadaports-fcolista-cbfc4f000399fb9f3d2705afe12fc4f0115c646d.tar.bz2
aports-fcolista-cbfc4f000399fb9f3d2705afe12fc4f0115c646d.tar.xz
main/qemu: upgrade to 0.14.0
Diffstat (limited to 'main/qemu')
-rw-r--r--main/qemu/APKBUILD16
-rw-r--r--main/qemu/qemu-libm.patch11
2 files changed, 23 insertions, 4 deletions
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 526e63b015..8d9d4ac229 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
-pkgver=0.13.0
-pkgrel=1
+pkgver=0.14.0
+pkgrel=0
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://www.nongnu.org/qemu/"
arch="all"
@@ -29,11 +29,18 @@ $pkgname-x86_64
$pkgname-img
"
source="http://savannah.nongnu.org/download/$pkgname/$pkgname-$pkgver.tar.gz
+ qemu-libm.patch
80-kvm.rules
"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
# avoid fdt till an updated release appears
sed -i -e 's:fdt="yes":fdt="no":' configure
# prevent docs to get automatically installed
@@ -55,7 +62,7 @@ build() {
--disable-linux-user \
--cc="${CC:-gcc}"
- make || return 1
+ make V=1 || return 1
}
package() {
@@ -98,5 +105,6 @@ img() {
"$subpkgdir"/usr/bin/
}
-md5sums="397a0d665da8ba9d3b9583629f3d6421 qemu-0.13.0.tar.gz
+md5sums="f9d145d5c09de9f0984ffe9bd1229970 qemu-0.14.0.tar.gz
+70a4336c31600ce00838b056f0d08452 qemu-libm.patch
66660f143235201249dc0648b39b86ee 80-kvm.rules"
diff --git a/main/qemu/qemu-libm.patch b/main/qemu/qemu-libm.patch
new file mode 100644
index 0000000000..c7f0db707b
--- /dev/null
+++ b/main/qemu/qemu-libm.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -29,7 +29,7 @@
+
+ $(call set-vpath, $(SRC_PATH):$(SRC_PATH)/hw)
+
+-LIBS+=-lz $(LIBS_TOOLS)
++LIBS+=-lm -lz $(LIBS_TOOLS)
+
+ ifdef BUILD_DOCS
+ DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 QMP/qmp-commands.txt