summaryrefslogtreecommitdiffstats
path: root/main/sg3_utils
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2010-09-26 11:14:02 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2010-09-27 12:23:07 +0000
commit9ec3b96eefd2b16ea74dd96eb0e21c607b409e84 (patch)
tree9260819dcc28cf5bcb00176c333dbcba74e7fbec /main/sg3_utils
parentb299866d8394a2908eca9fc0e2f14704f3235a35 (diff)
downloadaports-fcolista-9ec3b96eefd2b16ea74dd96eb0e21c607b409e84.tar.bz2
aports-fcolista-9ec3b96eefd2b16ea74dd96eb0e21c607b409e84.tar.xz
main/sg3_utils: new apkbuild
(cherry picked from commit 2c3f1b7f6811c98d120fd7a057e324cf521fef46)
Diffstat (limited to 'main/sg3_utils')
-rw-r--r--main/sg3_utils/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/sg3_utils/APKBUILD b/main/sg3_utils/APKBUILD
new file mode 100644
index 0000000000..617fe703e9
--- /dev/null
+++ b/main/sg3_utils/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=sg3_utils
+pkgver=1.29
+pkgrel=0
+pkgdesc="Generic SCSI utilities"
+url="http://sg.danny.cz/sg/sg3_utils.html"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://sg.danny.cz/sg/p/$pkgname-$pkgver.tgz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="17b8f2bc1b32bd036515683cc87328ea sg3_utils-1.29.tgz"