summaryrefslogtreecommitdiffstats
path: root/main/squid
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-22 08:15:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-22 08:16:46 +0000
commit9c3d51ed7510d8ba50ca2c96001499626dd8c6c2 (patch)
treed2aa399bf5f2a99b8cbee258881bfdbba28707e8 /main/squid
parent1bf1f80aa2ce7ecb554caaaee64932bdd5022c73 (diff)
downloadaports-fcolista-9c3d51ed7510d8ba50ca2c96001499626dd8c6c2.tar.bz2
aports-fcolista-9c3d51ed7510d8ba50ca2c96001499626dd8c6c2.tar.xz
main/squid: upgrade to 3.2.0.16
Diffstat (limited to 'main/squid')
-rw-r--r--main/squid/APKBUILD10
-rw-r--r--main/squid/squid-3.2.0.16-loggable-urlgroup.patch (renamed from main/squid/squid-3.2.0.12-loggable-urlgroup.patch)126
-rw-r--r--main/squid/squid.post-install5
3 files changed, 68 insertions, 73 deletions
diff --git a/main/squid/APKBUILD b/main/squid/APKBUILD
index 7ec326f9f1..e018f5db42 100644
--- a/main/squid/APKBUILD
+++ b/main/squid/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=squid
-pkgver=3.2.0.13
+pkgver=3.2.0.16
pkgrel=0
pkgdesc="A full-featured Web proxy cache server."
url="http://www.squid-cache.org"
-install="squid.pre-install squid.pre-upgrade squid.post-install"
+install="squid.pre-install squid.pre-upgrade"
pkgusers="squid"
pkggroups="squid"
arch="all"
@@ -19,7 +19,7 @@ linguas="af ar az bg ca cs da de el es et fa fi fr he hu hy id it ja ko lt
langdir="/usr/share/squid/errors"
source="http://www.squid-cache.org/Versions/v3/3.2/squid-$pkgver.tar.bz2
- squid-3.2.0.12-loggable-urlgroup.patch
+ squid-3.2.0.16-loggable-urlgroup.patch
cf_gen-pthread.patch
squid.initd
squid.confd
@@ -103,8 +103,8 @@ squid_kerb_auth() {
mv "$pkgdir"/usr/lib/squid/squid_kerb_auth "$subpkgdir"/usr/lib/squid/
}
-md5sums="cef6d63729b34404a3e463f0bd81b1e3 squid-3.2.0.13.tar.bz2
-084f7b1af1ac0cb8fea35c7a0905a80e squid-3.2.0.12-loggable-urlgroup.patch
+md5sums="1e2c1297992e151a1cafd8512f6cac1c squid-3.2.0.16.tar.bz2
+16e3b38996d4c5858e1478f8eb650876 squid-3.2.0.16-loggable-urlgroup.patch
c60237de253c02937f272d3b189d7679 cf_gen-pthread.patch
905e57c6d41414f54a75a5c0f9f7fac7 squid.initd
2897c725c201be53d3c9a7db0101bdf0 squid.confd
diff --git a/main/squid/squid-3.2.0.12-loggable-urlgroup.patch b/main/squid/squid-3.2.0.16-loggable-urlgroup.patch
index ee1646fe58..41193ba85f 100644
--- a/main/squid/squid-3.2.0.12-loggable-urlgroup.patch
+++ b/main/squid/squid-3.2.0.16-loggable-urlgroup.patch
@@ -1,37 +1,8 @@
-Index: squid-3.2.0.12/src/client_side_request.cc
-===================================================================
---- squid-3.2.0.12.orig/src/client_side_request.cc 2011-10-07 20:29:10.000000000 +0300
-+++ squid-3.2.0.12/src/client_side_request.cc 2011-10-07 21:54:38.000000000 +0300
-@@ -1165,6 +1165,15 @@
- redirect_state = REDIRECT_DONE;
-
- if (result) {
-+ if (result[0] == '!') {
-+ char *t = strchr(result+1, '!');
-+ if (t != NULL) {
-+ old_request->urlgroup.reset(NULL);
-+ old_request->urlgroup.append(result + 1, t - result - 1);
-+ result = t + 1;
-+ }
-+ }
-+
- http_status status = (http_status) atoi(result);
-
- if (status == HTTP_MOVED_PERMANENTLY
-@@ -1183,7 +1192,7 @@
- else
- debugs(85, DBG_CRITICAL, "ERROR: URL-rewrite produces invalid 303 redirect Location: " << result);
- }
-- } else if (strcmp(result, http->uri)) {
-+ } else if (result[0] != 0 && strcmp(result, http->uri)) {
- // XXX: validate the URL properly *without* generating a whole new request object right here.
- // XXX: the clone() should be done only AFTER we know the new URL is valid.
- HttpRequest *new_request = old_request->clone();
-Index: squid-3.2.0.12/src/HttpRequest.cc
-===================================================================
---- squid-3.2.0.12.orig/src/HttpRequest.cc 2011-10-07 21:02:45.000000000 +0300
-+++ squid-3.2.0.12/src/HttpRequest.cc 2011-10-07 21:03:45.000000000 +0300
-@@ -106,6 +106,7 @@
+diff --git a/src/HttpRequest.cc b/src/HttpRequest.cc
+index b464e65..0448078 100644
+--- a/src/HttpRequest.cc
++++ b/src/HttpRequest.cc
+@@ -107,6 +107,7 @@ HttpRequest::init()
peer_login = NULL; // not allocated/deallocated by this class
peer_domain = NULL; // not allocated/deallocated by this class
vary_headers = NULL;
@@ -39,7 +10,7 @@ Index: squid-3.2.0.12/src/HttpRequest.cc
myportname = null_string;
tag = null_string;
#if USE_AUTH
-@@ -154,6 +155,7 @@
+@@ -155,6 +156,7 @@ HttpRequest::clean()
range = NULL;
}
@@ -47,7 +18,7 @@ Index: squid-3.2.0.12/src/HttpRequest.cc
myportname.clean();
tag.clean();
-@@ -213,6 +215,7 @@
+@@ -214,6 +216,7 @@ HttpRequest::clone() const
copy->vary_headers = vary_headers ? xstrdup(vary_headers) : NULL;
// XXX: what to do with copy->peer_domain?
@@ -55,11 +26,11 @@ Index: squid-3.2.0.12/src/HttpRequest.cc
copy->myportname = myportname;
copy->tag = tag;
#if USE_AUTH
-Index: squid-3.2.0.12/src/HttpRequest.h
-===================================================================
---- squid-3.2.0.12.orig/src/HttpRequest.h 2011-10-07 21:02:45.000000000 +0300
-+++ squid-3.2.0.12/src/HttpRequest.h 2011-10-07 21:02:55.000000000 +0300
-@@ -187,6 +187,8 @@
+diff --git a/src/HttpRequest.h b/src/HttpRequest.h
+index dc44fea..989624d 100644
+--- a/src/HttpRequest.h
++++ b/src/HttpRequest.h
+@@ -187,6 +187,8 @@ public:
char *peer_domain; /* Configured peer forceddomain */
@@ -68,11 +39,52 @@ Index: squid-3.2.0.12/src/HttpRequest.h
String myportname; // Internal tag name= value from port this requests arrived in.
String tag; /* Internal tag for this request */
-Index: squid-3.2.0.12/src/format/Format.cc
-===================================================================
---- squid-3.2.0.12.orig/src/format/Format.cc 2011-10-07 21:33:38.000000000 +0300
-+++ squid-3.2.0.12/src/format/Format.cc 2011-10-07 21:41:45.000000000 +0300
-@@ -895,6 +895,12 @@
+diff --git a/src/client_side_request.cc b/src/client_side_request.cc
+index 0c3113b..d1947e9 100644
+--- a/src/client_side_request.cc
++++ b/src/client_side_request.cc
+@@ -1180,6 +1180,15 @@ ClientRequestContext::clientRedirectDone(char *result)
+ redirect_state = REDIRECT_DONE;
+
+ if (result) {
++ if (result[0] == '!') {
++ char *t = strchr(result+1, '!');
++ if (t != NULL) {
++ old_request->urlgroup.reset(NULL);
++ old_request->urlgroup.append(result + 1, t - result - 1);
++ result = t + 1;
++ }
++ }
++
+ http_status status = (http_status) atoi(result);
+
+ if (status == HTTP_MOVED_PERMANENTLY
+@@ -1198,7 +1207,7 @@ ClientRequestContext::clientRedirectDone(char *result)
+ else
+ debugs(85, DBG_CRITICAL, "ERROR: URL-rewrite produces invalid 303 redirect Location: " << result);
+ }
+- } else if (strcmp(result, http->uri)) {
++ } else if (result[0] != 0 && strcmp(result, http->uri)) {
+ // XXX: validate the URL properly *without* generating a whole new request object right here.
+ // XXX: the clone() should be done only AFTER we know the new URL is valid.
+ HttpRequest *new_request = old_request->clone();
+diff --git a/src/format/ByteCode.h b/src/format/ByteCode.h
+index 8e345df..ddb0f8f 100644
+--- a/src/format/ByteCode.h
++++ b/src/format/ByteCode.h
+@@ -65,6 +65,7 @@ typedef enum {
+ /*LFT_REQUEST_QUERY, */
+ LFT_REQUEST_VERSION_OLD_2X,
+ LFT_REQUEST_VERSION,
++ LFT_REQUEST_URLGROUP,
+
+ /* request header details pre-adaptation */
+ LFT_REQUEST_HEADER,
+diff --git a/src/format/Format.cc b/src/format/Format.cc
+index 18348e8..2e65886 100644
+--- a/src/format/Format.cc
++++ b/src/format/Format.cc
+@@ -907,6 +907,12 @@ Format::Format::assemble(MemBuf &mb, AccessLogEntry *al, int logSequenceNumber)
out = tmp;
break;
@@ -85,23 +97,11 @@ Index: squid-3.2.0.12/src/format/Format.cc
case LFT_SERVER_REQ_METHOD:
if (al->adapted_request) {
out = al->adapted_request->method.image();
-Index: squid-3.2.0.12/src/format/Tokens.h
-===================================================================
---- squid-3.2.0.12.orig/src/format/Tokens.h 2011-10-07 21:34:25.000000000 +0300
-+++ squid-3.2.0.12/src/format/Tokens.h 2011-10-07 21:40:26.000000000 +0300
-@@ -100,6 +100,7 @@
- /*LFT_REQUEST_QUERY, */
- LFT_REQUEST_VERSION_OLD_2X,
- LFT_REQUEST_VERSION,
-+ LFT_REQUEST_URLGROUP,
-
- /* Request-Line details sent to the server/peer */
- LFT_SERVER_REQ_METHOD,
-Index: squid-3.2.0.12/src/format/Tokens.cc
-===================================================================
---- squid-3.2.0.12.orig/src/format/Tokens.cc 2011-10-07 21:38:05.000000000 +0300
-+++ squid-3.2.0.12/src/format/Tokens.cc 2011-10-07 21:40:55.000000000 +0300
-@@ -114,6 +114,7 @@
+diff --git a/src/format/Token.cc b/src/format/Token.cc
+index 6859e0a..8a8e5e7 100644
+--- a/src/format/Token.cc
++++ b/src/format/Token.cc
+@@ -116,6 +116,7 @@ static TokenTableEntry TokenTable2C[] = {
{"rp", LFT_REQUEST_URLPATH_OLD_31},
/* { "rq", LFT_REQUEST_QUERY }, * / / * the query-string, INCLUDING the leading ? */
{"rv", LFT_REQUEST_VERSION},
diff --git a/main/squid/squid.post-install b/main/squid/squid.post-install
deleted file mode 100644
index 88df6d26f9..0000000000
--- a/main/squid/squid.post-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-chown squid:squid /var/cache/squid /var/log/squid
-exit 0
-