summaryrefslogtreecommitdiffstats
path: root/main/sudo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-04 09:54:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-04 09:54:39 +0000
commit63b794991b996569e05684c3edc46c51c3e337fe (patch)
treed68929e2457b5654051f9ccb06513c48b9c3057c /main/sudo
parente5bef288023563ed6b85764591d8d5310c1b05cd (diff)
downloadaports-fcolista-63b794991b996569e05684c3edc46c51c3e337fe.tar.bz2
aports-fcolista-63b794991b996569e05684c3edc46c51c3e337fe.tar.xz
main/sudo: upgrade to 1.8.0 and fix the libcrypt error
Diffstat (limited to 'main/sudo')
-rw-r--r--main/sudo/APKBUILD27
-rw-r--r--main/sudo/libcrypt.patch11
2 files changed, 30 insertions, 8 deletions
diff --git a/main/sudo/APKBUILD b/main/sudo/APKBUILD
index e203f1cb99..f09c812b89 100644
--- a/main/sudo/APKBUILD
+++ b/main/sudo/APKBUILD
@@ -1,35 +1,46 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sudo
-pkgver=1.7.4p6
+pkgver=1.8.0
if [ "${pkgver%_*}" != "$pkgver" ]; then
_realver=${pkgver%_*}${pkgver#*_}
else
_realver=$pkgver
fi
-pkgrel=0
+pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root"
url="http://www.sudo.ws/sudo/"
arch="all"
license='custom ISC'
+makedepends=
depends=
-source="ftp://ftp.sudo.ws/pub/sudo/$pkgname-$_realver.tar.gz"
subpackages="$pkgname-doc"
+source="ftp://ftp.sudo.ws/pub/sudo/$pkgname-$_realver.tar.gz
+ libcrypt.patch"
-build() {
- cd "$srcdir/$pkgname-$_realver"
+_builddir="$srcdir"/$pkgname-$_realver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--with-env-editor \
--without-pam \
--without-skey \
- --without-offensive-insults \
|| return 1
make || return 1
}
package() {
- cd "$srcdir/$pkgname-$_realver"
+ cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
}
-md5sums="1ae12d3d22e7ffedbf2db26f957676f0 sudo-1.7.4p6.tar.gz"
+md5sums="fa0a35330691af14cb1869f64a65aebc sudo-1.8.0.tar.gz
+429d9613091f1f3f19ce8def5b3032b3 libcrypt.patch"
diff --git a/main/sudo/libcrypt.patch b/main/sudo/libcrypt.patch
new file mode 100644
index 0000000000..0bab038632
--- /dev/null
+++ b/main/sudo/libcrypt.patch
@@ -0,0 +1,11 @@
+--- ./plugins/sudoers/Makefile.in.orig
++++ ./plugins/sudoers/Makefile.in
+@@ -45,7 +45,7 @@
+ # Libraries
+ LIBS = $(top_builddir)/common/libcommon.la $(top_builddir)/@ac_config_libobj_dir@/libreplace.la
+ NET_LIBS = @NET_LIBS@
+-SUDOERS_LIBS = @SUDOERS_LIBS@ @AFS_LIBS@ @GETGROUPS_LIB@ $(LIBS) $(NET_LIBS) @ZLIB@
++SUDOERS_LIBS = @SUDOERS_LIBS@ @AFS_LIBS@ @GETGROUPS_LIB@ $(LIBS) $(NET_LIBS) @ZLIB@ -lcrypt
+ REPLAY_LIBS = @REPLAY_LIBS@ @ZLIB@
+
+ # C preprocessor flags