summaryrefslogtreecommitdiffstats
path: root/main/xulrunner
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-15 12:57:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-15 14:32:38 +0000
commit0c96f83bef7f3cf30ffab693dd90126bb87e8ce1 (patch)
tree237d806ec5f037cd89ba8cb4658d52124533e4b6 /main/xulrunner
parenta50fdbd9146b48006f82f69422e9c475d52a14d6 (diff)
downloadaports-fcolista-0c96f83bef7f3cf30ffab693dd90126bb87e8ce1.tar.bz2
aports-fcolista-0c96f83bef7f3cf30ffab693dd90126bb87e8ce1.tar.xz
main/xulrunner: upgrade to 6.0
Diffstat (limited to 'main/xulrunner')
-rw-r--r--main/xulrunner/0001-Use-C99-math-isfinite.patch39
-rw-r--r--main/xulrunner/APKBUILD20
-rw-r--r--main/xulrunner/mozilla-bsdiff-libbz2.patch33
-rw-r--r--main/xulrunner/mozjs-c99math.patch21
-rw-r--r--main/xulrunner/xpcom-c99math.patch10
5 files changed, 65 insertions, 58 deletions
diff --git a/main/xulrunner/0001-Use-C99-math-isfinite.patch b/main/xulrunner/0001-Use-C99-math-isfinite.patch
new file mode 100644
index 0000000000..b9ead9117c
--- /dev/null
+++ b/main/xulrunner/0001-Use-C99-math-isfinite.patch
@@ -0,0 +1,39 @@
+From f7c52ff6334ce158da23750e63655df41e73fc31 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 15 Aug 2011 07:57:16 +0000
+Subject: [PATCH] Use C99 math isfinite
+
+---
+ content/base/public/nsContentUtils.h | 2 +-
+ js/src/ctypes/CTypes.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/content/base/public/nsContentUtils.h b/content/base/public/nsContentUtils.h
+index a69d4ef..b4d8e67 100644
+--- a/content/base/public/nsContentUtils.h
++++ b/content/base/public/nsContentUtils.h
+@@ -1994,7 +1994,7 @@ inline NS_HIDDEN_(PRBool) NS_FloatIsFinite(jsdouble f) {
+ #ifdef WIN32
+ return _finite(f);
+ #else
+- return finite(f);
++ return isfinite(f);
+ #endif
+ }
+
+diff --git a/js/src/ctypes/CTypes.cpp b/js/src/ctypes/CTypes.cpp
+index 0644817..5dbb906 100644
+--- a/js/src/ctypes/CTypes.cpp
++++ b/js/src/ctypes/CTypes.cpp
+@@ -467,7 +467,7 @@ static inline bool FloatIsFinite(jsdouble f) {
+ #ifdef WIN32
+ return _finite(f) != 0;
+ #else
+- return finite(f);
++ return isfinite(f);
+ #endif
+ }
+
+--
+1.7.6
+
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index c33e79cc3f..03ddc34a8d 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xulrunner
-pkgver=5.0.1
-_ffoxver=5.0.1
+pkgver=6.0
+_ffoxver=6.0
pkgrel=0
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
@@ -55,8 +55,7 @@ source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
mozjs-c99math.patch
xpcom-c99math.patch
-
- mozilla-bsdiff-libbz2.patch"
+ "
_builddir="${srcdir}/mozilla-release"
prepare() {
@@ -88,6 +87,11 @@ package() {
cd "$_builddir"
make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1
+ # make install does not install xpt.py but its needed by firefox
+ mkdir -p "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin
+ cp xpcom/typelib/xpt/tools/xpt.py \
+ "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin/
+
msg "Setting up compatibility symlinks..."
ln -sf /usr/lib/xulrunner-${pkgver}/libxul.so "${pkgdir}"/usr/lib/libxul.so
ln -sf /usr/lib/xulrunner-${pkgver}/libxpcom.so "${pkgdir}"/usr/lib/libxpcom.so
@@ -96,6 +100,7 @@ package() {
dev() {
replaces="xulrunner"
+ depends="xulrunner"
mkdir -p "${subpkgdir}"/usr/lib
mv "${pkgdir}"/usr/lib/xulrunner-devel-${pkgver} "${subpkgdir}"/usr/lib
@@ -103,12 +108,11 @@ dev() {
mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
}
-md5sums="6d1f43e402cec84459a3d7f950bd5192 firefox-5.0.1.source.tar.bz2
+md5sums="1840185865a1a8975df4a3db59080ddc firefox-6.0.source.tar.bz2
cc43a2bd96bd2395aa72d0bbb88e5594 mozconfig
86d33a17286131d9ef4cdfb35ee56f1f fix-xulrunner-launcher.patch
02c23dc4ebd88e445533314716331818 mozilla-pkgconfig.patch
30053b8b5811cc0676bfe7d7d7ffaa4a xulrunner-jemalloc-aslr.patch
d38ecbb7bb31032d3e1ced8939e26abd xulrunner-mozalloc.patch
-b187440207e773e9be606594d2c99216 mozjs-c99math.patch
-128d37fab6fbcb1d0b994e8023e701e0 xpcom-c99math.patch
-88c5b4db4e7910b7b99cdee96847c13d mozilla-bsdiff-libbz2.patch"
+abbef7f783ad5d99a9cdbf9e358fafcd mozjs-c99math.patch
+68709c9aad5b7e46e63787fc648d7ae7 xpcom-c99math.patch"
diff --git a/main/xulrunner/mozilla-bsdiff-libbz2.patch b/main/xulrunner/mozilla-bsdiff-libbz2.patch
deleted file mode 100644
index 52e4c92996..0000000000
--- a/main/xulrunner/mozilla-bsdiff-libbz2.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-# HG changeset patch
-# User Mike Hommey <mh+mozilla@glandium.org>
-# Date 1302680663 -7200
-# Node ID 0583d58b20a3a0789c46f19ed505cb6e96602ec9
-# Parent 0138798a072ad15edce15d614923a03256946218
-Bug 644692 - Fix bsdiff build failure with system bzip2. r=ted
-
-diff --git a/other-licenses/bsdiff/Makefile.in b/other-licenses/bsdiff/Makefile.in
---- a/other-licenses/bsdiff/Makefile.in
-+++ b/other-licenses/bsdiff/Makefile.in
-@@ -43,17 +43,21 @@ VPATH = @srcdir@
-
- include $(DEPTH)/config/autoconf.mk
-
- # This program is output to dist/host/bin because it is only needed by the
- # build system and is not intended to be included in Mozilla distributions.
- HOST_PROGRAM = mbsdiff$(BIN_SUFFIX)
- HOST_CSRCS = bsdiff.c
-
-+ifdef MOZ_NATIVE_BZ2
-+HOST_LIBS += $(BZ2_LIBS)
-+else
- HOST_LIBS += $(DIST)/host/lib/$(LIB_PREFIX)hostbz2.$(LIB_SUFFIX)
-+endif
-
- ifneq (,$(filter WINCE WINNT,$(HOST_OS_ARCH)))
- HOST_EXTRA_LIBS += $(call EXPAND_LIBNAME,Ws2_32)
- endif
-
- LOCAL_INCLUDES += -I$(topsrcdir)/toolkit/mozapps/update/updater
-
- include $(topsrcdir)/config/rules.mk
-
diff --git a/main/xulrunner/mozjs-c99math.patch b/main/xulrunner/mozjs-c99math.patch
index fdf346e495..a4f81b62c7 100644
--- a/main/xulrunner/mozjs-c99math.patch
+++ b/main/xulrunner/mozjs-c99math.patch
@@ -1,14 +1,3 @@
---- mozilla-1.9.2.orig/js/src/jsnum.h
-+++ mozilla-1.9.2/js/src/jsnum.h
-@@ -98,7 +98,7 @@
- #ifdef WIN32
- return _finite(d);
- #else
-- return finite(d);
-+ return isfinite(d);
- #endif
- }
-
--- mozilla-2.0.orig/js/src/ctypes/CTypes.cpp
+++ mozilla-2.0/js/src/ctypes/CTypes.cpp
@@ -464,7 +464,7 @@
@@ -20,14 +9,18 @@
#endif
}
---- mozilla-2.0.orig/content/base/public/nsContentUtils.h
-+++ mozilla-2.0/content/base/public/nsContentUtils.h
-@@ -1942,7 +1942,7 @@
+--- ./content/base/public/nsContentUtils.h.orig
++++ ./content/base/public/nsContentUtils.h
+@@ -1994,7 +1994,11 @@
#ifdef WIN32
return _finite(f);
#else
- return finite(f);
++#ifdef _GLIBCXX_CMATH
++ return std::isfinite(f);
++#else
+ return isfinite(f);
++#endif
#endif
}
diff --git a/main/xulrunner/xpcom-c99math.patch b/main/xulrunner/xpcom-c99math.patch
index 955f964eb8..3222c7f206 100644
--- a/main/xulrunner/xpcom-c99math.patch
+++ b/main/xulrunner/xpcom-c99math.patch
@@ -1,11 +1,15 @@
---- mozilla-release.orig/xpcom/ds/nsMathUtils.h
-+++ mozilla-release/xpcom/ds/nsMathUtils.h
-@@ -170,7 +170,7 @@
+--- ./xpcom/ds/nsMathUtils.h.orig
++++ ./xpcom/ds/nsMathUtils.h
+@@ -151,7 +151,11 @@
// NOTE: '!!' casts an int to bool without spamming MSVC warning C4800.
return !!_finite(d);
#else
- return finite(d);
++#ifdef _GLIBCXX_CMATH
++ return std::isfinite(d);
++#else
+ return isfinite(d);
++#endif
#endif
}