summaryrefslogtreecommitdiffstats
path: root/main/xulrunner
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-06-07 06:14:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-06-07 06:25:06 +0000
commit27fc6a256ddd821464fa170dc41316247ccf0dc3 (patch)
treeeca67c1c5f32ba5f5df0218618e741ad4740bd9e /main/xulrunner
parent0949391ce69b554ae0c1cbd54c488a9b324aa768 (diff)
downloadaports-fcolista-27fc6a256ddd821464fa170dc41316247ccf0dc3.tar.bz2
aports-fcolista-27fc6a256ddd821464fa170dc41316247ccf0dc3.tar.xz
main/xulrunner: upgrade to 13.0
Diffstat (limited to 'main/xulrunner')
-rw-r--r--main/xulrunner/APKBUILD8
-rw-r--r--main/xulrunner/ff9-aslr-fix.patch40
2 files changed, 3 insertions, 45 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index 4b0cf7d425..b1023d5bb8 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xulrunner
-pkgver=12.0
+pkgver=13.0
_ffoxver=$pkgver
-pkgrel=2
+pkgrel=0
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -49,7 +49,6 @@ source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
0002-Use-C99-math-isfinite.patch
0003-xulrunner-jemalloc-aslr.patch
0004-xulrunner-malloc_usable_size.patch
- ff9-aslr-fix.patch
cairo.patch
"
@@ -105,10 +104,9 @@ dev() {
mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
}
-md5sums="80c3e5927274de7f181fb5f931ac5fd4 firefox-12.0.source.tar.bz2
+md5sums="f50ca7656eec47030b396f39075fa980 firefox-13.0.source.tar.bz2
b0f7d491bc800b69ec718667a4b08acb mozconfig
1867db217d10722675c88b655db8c2d7 0002-Use-C99-math-isfinite.patch
7faa279d64c9ec2e7abc7c0497c7e07e 0003-xulrunner-jemalloc-aslr.patch
d12e0636e1f9877ef2d1df45d5834c87 0004-xulrunner-malloc_usable_size.patch
-96b40acd003a0a586e408bf09ae5af1d ff9-aslr-fix.patch
6a3942d96c7ce3c63251761cc12c8349 cairo.patch"
diff --git a/main/xulrunner/ff9-aslr-fix.patch b/main/xulrunner/ff9-aslr-fix.patch
deleted file mode 100644
index 4e4297d0ed..0000000000
--- a/main/xulrunner/ff9-aslr-fix.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- ./js/src/jsgcchunk.cpp 2011-12-22 17:13:21.000000000 +0000
-+++ ./js/src/jsgcchunk.cpp 2011-12-22 17:18:31.000000000 +0000
-@@ -213,7 +213,7 @@
- #elif defined(XP_UNIX)
-
- /* Required on Solaris 10. Might improve performance elsewhere. */
--# if defined(SOLARIS) && defined(MAP_ALIGN)
-+# if (defined(SOLARIS) && defined(MAP_ALIGN)) || defined(MOZ_MEMORY_LINUX)
- # define JS_GC_HAS_MAP_ALIGN
-
- static void *
---- ./js/src/jsgcchunk.cpp 2011-12-22 17:55:24.000000000 +0000
-+++ ./js/src/jsgcchunk.cpp 2011-12-22 18:02:24.000000000 +0000
-@@ -226,12 +226,24 @@
- #ifdef SOLARIS
- void *p = mmap((caddr_t) alignment, size, PROT_READ | PROT_WRITE,
- MAP_PRIVATE | MAP_NOSYNC | MAP_ALIGN | MAP_ANON, -1, 0);
-+ if (p == MAP_FAILED)
-+ return NULL;
- #else
-- void *p = mmap((void *) alignment, size, PROT_READ | PROT_WRITE,
-- MAP_PRIVATE | MAP_NOSYNC | MAP_ALIGN | MAP_ANON, -1, 0);
--#endif
-+ void *p = mmap(NULL, size + alignment, PROT_READ | PROT_WRITE,
-+ MAP_PRIVATE | MAP_NOSYNC | MAP_ANON, -1, 0);
- if (p == MAP_FAILED)
- return NULL;
-+ uintptr_t aligned_ret;
-+ size_t extra_size;
-+
-+ aligned_ret = (uintptr_t)p + alignment - 1;
-+ aligned_ret &= ~(alignment - 1);
-+ extra_size = aligned_ret - (uintptr_t)p;
-+ munmap(p, extra_size);
-+ munmap(p + extra_size + size, alignment - extra_size);
-+ p = (void *)aligned_ret;
-+#endif
-+
- return p;
- }