summaryrefslogtreecommitdiffstats
path: root/testing/cherokee
diff options
context:
space:
mode:
authorJesse Young <jlyo@jlyo.org>2011-11-25 12:46:26 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-01 07:15:51 +0000
commitae1967b66eba132dd8c9fa5b5f57712d012b6647 (patch)
treefca1c166178cd340ea41b6d3794cf58c4152f2f4 /testing/cherokee
parent379338be8b4cd31b24080f7f01ae14fe124a84ae (diff)
downloadaports-fcolista-ae1967b66eba132dd8c9fa5b5f57712d012b6647.tar.bz2
aports-fcolista-ae1967b66eba132dd8c9fa5b5f57712d012b6647.tar.xz
Replace instances of "--chuid" to "--user" in initd scripts
Fixes #776 Signed-off-by: Jesse Young <jlyo@jlyo.org>
Diffstat (limited to 'testing/cherokee')
-rw-r--r--testing/cherokee/APKBUILD10
-rwxr-xr-xtesting/cherokee/cherokee.initd2
2 files changed, 6 insertions, 6 deletions
diff --git a/testing/cherokee/APKBUILD b/testing/cherokee/APKBUILD
index a4ab7f7d45..ca8330a026 100644
--- a/testing/cherokee/APKBUILD
+++ b/testing/cherokee/APKBUILD
@@ -1,8 +1,8 @@
-# Contributor: Mika Havela <mika.havela@gmail.com>
+# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=cherokee
pkgver=1.2.98
-pkgrel=1
+pkgrel=2
pkgdesc="A very fast, flexible and easy to configure Web Server"
url="http://www.cherokee-project.com/"
arch="all"
@@ -31,9 +31,9 @@ build() {
package() {
cd "$_builddir"
-
+
make -j1 DESTDIR="$pkgdir" install || return 1
-
+
install -m755 -D "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname || return 1
install -m644 -D "$srcdir"/$pkgname.confd \
@@ -41,5 +41,5 @@ package() {
}
md5sums="21b01e7d45c0e82ecc0c4257a9c27feb cherokee-1.2.98.tar.gz
-4180dbb6701f928054079aa1e3bd5ebc cherokee.initd
+8cc44726585fa04a2772a0c3faa6a72d cherokee.initd
bd6a840f72c630ce1eaabe058097584f cherokee.confd"
diff --git a/testing/cherokee/cherokee.initd b/testing/cherokee/cherokee.initd
index 6aed337b6f..5e88e069c3 100755
--- a/testing/cherokee/cherokee.initd
+++ b/testing/cherokee/cherokee.initd
@@ -15,7 +15,7 @@ start() {
ebegin "Starting ${NAME}"
start-stop-daemon --start --quiet \
--pidfile /var/run/${NAME}.pid \
- --chuid ${DAEMON_USER}:${DAEMON_GROUP} \
+ --user ${DAEMON_USER}:${DAEMON_GROUP} \
--exec ${DAEMON} -- ${OPTS}
eend $?
}