summaryrefslogtreecommitdiffstats
path: root/testing/dhex
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-23 12:33:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-23 12:33:19 +0000
commitc0515f500bcc2309cdc8a2c65f157c45fdba57c3 (patch)
tree519064503d426fa9d742a479b11dc09c0236d6ae /testing/dhex
parente6ac7b39583124cfbc1de23050ce8325e177c9e9 (diff)
downloadaports-fcolista-c0515f500bcc2309cdc8a2c65f157c45fdba57c3.tar.bz2
aports-fcolista-c0515f500bcc2309cdc8a2c65f157c45fdba57c3.tar.xz
testing/dhex: new aport
Ncurses hex editor http://www.dettus.net/dhex/
Diffstat (limited to 'testing/dhex')
-rw-r--r--testing/dhex/APKBUILD41
-rw-r--r--testing/dhex/makefile.patch49
2 files changed, 90 insertions, 0 deletions
diff --git a/testing/dhex/APKBUILD b/testing/dhex/APKBUILD
new file mode 100644
index 0000000000..d205c47842
--- /dev/null
+++ b/testing/dhex/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dhex
+pkgver=0.66
+pkgrel=0
+pkgdesc="Ncurses hex editor"
+url="http://www.dettus.net/dhex/"
+arch="all"
+license="GPL"
+depends=""
+makedepends="ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.dettus.net/dhex/dhex_0.66.tar.gz
+ makefile.patch"
+
+_builddir="$srcdir"/dhex_$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" \
+ mandir=/usr/share/man \
+ prefix=/usr/bin
+}
+
+md5sums="304a91cfd9481b2ddf418f3a943190e1 dhex_0.66.tar.gz
+de16e09d3b416650d84ef39235cd2917 makefile.patch"
diff --git a/testing/dhex/makefile.patch b/testing/dhex/makefile.patch
new file mode 100644
index 0000000000..9e7788b409
--- /dev/null
+++ b/testing/dhex/makefile.patch
@@ -0,0 +1,49 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -1,12 +1,22 @@
+-CC= gcc
+-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
++CC?= gcc
++LDFLAGS?= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
+ CPPFLAGS= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
+-CFLAGS= -O3 -Wall -std=c99
++CFLAGS?= -O3 -Wall -std=c99
+ #CFLAGS+= -ffunction-sections -fdata-sections
+ #LDFLAGS+= --gc-sections
+ LIBS= -lncurses
+-DESTDIR= /usr/local/
+
++prefix= /usr/local
++bindir= $(prefix)/bin
++mandir= $(prefix)/man
++man1dir= $(mandir)/man1
++man5dir= $(mandir)/man5
++DESTDIR=
++
++MKDIR_P= install -d
++INSTALL= install
++
++
+ OFILES=buffers.o \
+ configfile.o \
+ correlation.o \
+@@ -27,14 +37,11 @@
+ $(CC) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
+
+ install:all
+- strip dhex
+- cp dhex $(DESTDIR)/bin
+- cp dhex.1 $(DESTDIR)/man/man1
+- cp dhexrc.5 $(DESTDIR)/man/man5
+- cp dhex_markers.5 $(DESTDIR)/man/man5
+- cp dhex_searchlog.5 $(DESTDIR)/man/man5
+-
+-
++ $(MKDIR_P) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir) $(DESTDIR)$(man5dir)
++ $(INSTALL) -m755 dhex $(DESTDIR)$(bindir)
++ $(INSTALL) -m644 dhex.1 $(DESTDIR)$(man1dir)
++ $(INSTALL) -m644 dhexrc.5 dhex_markers.5 dhex_searchlog.5 \
++ $(DESTDIR)$(man5dir)
+
+ .c.o:
+ $(CC) $< -c -I. $(CPPFLAGS) $(CFLAGS) $(OPTIONS)