summaryrefslogtreecommitdiffstats
path: root/testing/gource
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-17 07:53:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-17 08:59:38 +0000
commit53c2daf2a456f2b9274ac120fc89815e0269c652 (patch)
tree3c27159d884801f1879e5e7d01e61b8a89c9e55e /testing/gource
parent2a25165a167786546cf05dc29090542dab19e8f9 (diff)
downloadaports-fcolista-53c2daf2a456f2b9274ac120fc89815e0269c652.tar.bz2
aports-fcolista-53c2daf2a456f2b9274ac120fc89815e0269c652.tar.xz
testing/gource: upgrade to 0.38
Diffstat (limited to 'testing/gource')
-rw-r--r--testing/gource/APKBUILD22
-rw-r--r--testing/gource/logmill.patch11
2 files changed, 28 insertions, 5 deletions
diff --git a/testing/gource/APKBUILD b/testing/gource/APKBUILD
index 6e815c9519..a42dbcf5cf 100644
--- a/testing/gource/APKBUILD
+++ b/testing/gource/APKBUILD
@@ -1,20 +1,31 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=gource
-pkgver=0.35
-pkgrel=3
+pkgver=0.38
+pkgrel=0
pkgdesc="Software version control visualization"
url="http://code.google.com/p/gource"
arch="all"
license="GPL3"
depends=
depends_dev="ftgl-dev sdl-dev sdl_image-dev pcre-dev glew-dev libpng-dev
- jpeg-dev"
+ jpeg-dev glu-dev boost-dev glm-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
-source="http://gource.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+patches="logmill.patch"
+source="http://gource.googlecode.com/files/$pkgname-$pkgver.tar.gz
+ $patches"
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ local _patch
+ for _patch in $patches; do
+ msg $_patch
+ patch -p1 -i "$srcdir"/$_patch || return 1
+ done
+}
+
build() {
cd "$_builddir"
./configure --prefix=/usr
@@ -26,4 +37,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="6d4f776d314da3ae5d309cb580b83a9f gource-0.35.tar.gz"
+md5sums="6584241879dbb6dfaecc6ae6b58ad38c gource-0.38.tar.gz
+d9052d5c8e0db9b373a75f42ec6bebad logmill.patch"
diff --git a/testing/gource/logmill.patch b/testing/gource/logmill.patch
new file mode 100644
index 0000000000..4ed4e998f9
--- /dev/null
+++ b/testing/gource/logmill.patch
@@ -0,0 +1,11 @@
+--- ./src/logmill.cpp.orig
++++ ./src/logmill.cpp
+@@ -176,7 +176,7 @@ RCommitLog* RLogMill::fetchLog(std::string& log_format) {
+ logfile = repo_path.string();
+ }
+ }
+- } catch(boost::filesystem3::filesystem_error& error) {
++ } catch(boost::filesystem::filesystem_error& error) {
+ }
+ }
+