summaryrefslogtreecommitdiffstats
path: root/testing/libfetch/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-10 09:37:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-10 09:37:10 +0000
commit626136ae6a1af7d11a837d98ca9411845b519b62 (patch)
treeea6671aca577d90fef2a8f557a8755d82dbb5df8 /testing/libfetch/APKBUILD
parent00da0c111d7e307767e2f2d832a814faeb8504c0 (diff)
downloadaports-fcolista-626136ae6a1af7d11a837d98ca9411845b519b62.tar.bz2
aports-fcolista-626136ae6a1af7d11a837d98ca9411845b519b62.tar.xz
testing/libfetch: new aport
URL based download library http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/
Diffstat (limited to 'testing/libfetch/APKBUILD')
-rw-r--r--testing/libfetch/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/libfetch/APKBUILD b/testing/libfetch/APKBUILD
new file mode 100644
index 0000000000..c224256a17
--- /dev/null
+++ b/testing/libfetch/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libfetch
+pkgver=2.30
+pkgrel=0
+pkgdesc="URL based download library"
+url="http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/"
+license="BSD"
+depends=
+makedepends="openssl-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="Makefile
+ ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cp "$srcdir"/Makefile "$_builddir"
+}
+
+build () {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR=$pkgdir install
+}
+md5sums="d811891db445b30515ac17c5bc0ab2ce Makefile
+ffa85bc269144d5e86ca6f81c5dc5ca5 libfetch-2.30.tar.gz"