summaryrefslogtreecommitdiffstats
path: root/testing/lua-ldoc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-09-27 08:27:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-09-27 08:38:26 +0000
commitf05ba182799f9d93fb9e202e37dce654d902ffd7 (patch)
treee3ab9e4c05061e728f4f1b5cf9dc25d1953122c9 /testing/lua-ldoc
parent230c3777579499822b97ed38496afd138eeced04 (diff)
downloadaports-fcolista-f05ba182799f9d93fb9e202e37dce654d902ffd7.tar.bz2
aports-fcolista-f05ba182799f9d93fb9e202e37dce654d902ffd7.tar.xz
testing/lua-ldoc: new aport
Documentation tool for Lua http://github.com/stevedonovan/LDoc
Diffstat (limited to 'testing/lua-ldoc')
-rw-r--r--testing/lua-ldoc/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/lua-ldoc/APKBUILD b/testing/lua-ldoc/APKBUILD
new file mode 100644
index 0000000000..3aa4b63d2f
--- /dev/null
+++ b/testing/lua-ldoc/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-ldoc
+pkgver=1.0
+pkgrel=0
+pkgdesc="Documentation tool for Lua"
+url="http://github.com/stevedonovan/LDoc"
+arch="noarch"
+license="MIT"
+depends="lua-penlight"
+makedepends="lua-dev"
+install=""
+subpackages=
+source="http://stevedonovan.github.com/files/ldoc-$pkgver.zip"
+
+_luashare=/usr/share/lua/5.1
+_builddir="$srcdir"/LDoc
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i '1i \
+#!/usr/bin/env lua' ldoc.lua
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 ldoc.lua "$pkgdir"/usr/bin/ldoc || return 1
+ install -d "$pkgdir"/$_luashare || return 1
+ cp -a ldoc "$pkgdir"/$_luashare/
+}
+
+md5sums="fcfb9afadd49c672f0cb553f490b2455 ldoc-1.0.zip"