summaryrefslogtreecommitdiffstats
path: root/testing/lua-microlight
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-06-13 14:43:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-06-13 14:48:53 +0000
commit8a1810796720022394c1b42a1da65deef5e25d98 (patch)
treea0fdc4a00632bea3e38badcf0be0d004d32301b4 /testing/lua-microlight
parentc760160666867f50608315ed85880625d3a88bb1 (diff)
downloadaports-fcolista-8a1810796720022394c1b42a1da65deef5e25d98.tar.bz2
aports-fcolista-8a1810796720022394c1b42a1da65deef5e25d98.tar.xz
testing/lua-microlight: upgrade to 1.0
Diffstat (limited to 'testing/lua-microlight')
-rw-r--r--testing/lua-microlight/APKBUILD39
-rw-r--r--testing/lua-microlight/Microlight.git/HEAD1
-rw-r--r--testing/lua-microlight/Microlight.git/config6
-rw-r--r--testing/lua-microlight/Microlight.git/description1
-rwxr-xr-xtesting/lua-microlight/Microlight.git/hooks/applypatch-msg.sample15
-rwxr-xr-xtesting/lua-microlight/Microlight.git/hooks/commit-msg.sample24
-rwxr-xr-xtesting/lua-microlight/Microlight.git/hooks/post-update.sample8
-rwxr-xr-xtesting/lua-microlight/Microlight.git/hooks/pre-applypatch.sample14
-rwxr-xr-xtesting/lua-microlight/Microlight.git/hooks/pre-commit.sample50
-rwxr-xr-xtesting/lua-microlight/Microlight.git/hooks/pre-rebase.sample169
-rwxr-xr-xtesting/lua-microlight/Microlight.git/hooks/prepare-commit-msg.sample36
-rwxr-xr-xtesting/lua-microlight/Microlight.git/hooks/update.sample128
-rw-r--r--testing/lua-microlight/Microlight.git/info/exclude6
-rw-r--r--testing/lua-microlight/Microlight.git/objects/pack/pack-b24eeb410b7f82331a4c067294ec2b9bd38f24ed.idxbin0 -> 2360 bytes
-rw-r--r--testing/lua-microlight/Microlight.git/objects/pack/pack-b24eeb410b7f82331a4c067294ec2b9bd38f24ed.packbin0 -> 24275 bytes
-rw-r--r--testing/lua-microlight/Microlight.git/packed-refs2
-rw-r--r--testing/lua-microlight/lua-microlight.tar0
17 files changed, 493 insertions, 6 deletions
diff --git a/testing/lua-microlight/APKBUILD b/testing/lua-microlight/APKBUILD
index 632a653339..5d50d473bf 100644
--- a/testing/lua-microlight/APKBUILD
+++ b/testing/lua-microlight/APKBUILD
@@ -1,19 +1,46 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua-microlight
-pkgver=0_git20120215
+pkgver=1.0
pkgrel=0
pkgdesc="a really compact set of general Lua functions"
url="http://stevedonovan.github.com/microlight/"
arch="noarch"
license="MIT"
depends="lua"
-makedepends="wget"
+makedepends=""
install=""
subpackages=""
-source="https://raw.github.com/gist/1834789/2bbb01662de1d83af93d2bd2990fee229b473d54/ml.lua"
-_builddir=
+_fmt=tar.gz
+
+source="http://dev.alpinelinux.org/archive/lua-microlight/lua-microlight-$pkgver.$_fmt"
+
+_giturl="git://github.com/stevedonovan/Microlight.git"
+_upload=dev.alpinelinux.org:/archive/lua-microlight
+_builddir="$srcdir"/lua-microlight-$pkgver
+
+archivetag() {
+ local _tag=$pkgver
+ local _pkg=$pkgname-$_tag.$_fmt
+ mkdir -p "$srcdir"
+ cd "$srcdir"
+ rm -rf "$pkgname"
+ git clone --bare $_giturl || return 1
+ git --git-dir ${_giturl##*/} archive \
+ --format $_fmt \
+ --prefix $pkgname-$pkgver/ \
+ --output $_pkg \
+ $_tag \
+ || return 1
+ msg "New snapshot: $_pkg"
+ if [ -n "$_upload" ]; then
+ msg "Uploading to $_upload"
+ scp $_pkg $_upload || return 1
+ abump $pkgname-$_tag
+ fi
+}
+
prepare() {
local i
cd "$_builddir"
@@ -30,7 +57,7 @@ build() {
package() {
cd "$_builddir"
- install -Dm644 "$srcdir"/ml.lua "$pkgdir"/usr/share/lua/5.1/ml.lua
+ install -Dm644 "$_builddir"/ml.lua "$pkgdir"/usr/share/lua/5.1/ml.lua
}
-md5sums="0a1e55c9babf6c093aa24f391c07cfd7 ml.lua"
+md5sums="3441e61bd170c8b4ddcd7df14072bdcb lua-microlight-1.0.tar.gz"
diff --git a/testing/lua-microlight/Microlight.git/HEAD b/testing/lua-microlight/Microlight.git/HEAD
new file mode 100644
index 0000000000..cb089cd89a
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/HEAD
@@ -0,0 +1 @@
+ref: refs/heads/master
diff --git a/testing/lua-microlight/Microlight.git/config b/testing/lua-microlight/Microlight.git/config
new file mode 100644
index 0000000000..83dff9c588
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/config
@@ -0,0 +1,6 @@
+[core]
+ repositoryformatversion = 0
+ filemode = true
+ bare = true
+[remote "origin"]
+ url = git://github.com/stevedonovan/Microlight.git
diff --git a/testing/lua-microlight/Microlight.git/description b/testing/lua-microlight/Microlight.git/description
new file mode 100644
index 0000000000..498b267a8c
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/description
@@ -0,0 +1 @@
+Unnamed repository; edit this file 'description' to name the repository.
diff --git a/testing/lua-microlight/Microlight.git/hooks/applypatch-msg.sample b/testing/lua-microlight/Microlight.git/hooks/applypatch-msg.sample
new file mode 100755
index 0000000000..8b2a2fe84f
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/hooks/applypatch-msg.sample
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# An example hook script to check the commit log message taken by
+# applypatch from an e-mail message.
+#
+# The hook should exit with non-zero status after issuing an
+# appropriate message if it wants to stop the commit. The hook is
+# allowed to edit the commit message file.
+#
+# To enable this hook, rename this file to "applypatch-msg".
+
+. git-sh-setup
+test -x "$GIT_DIR/hooks/commit-msg" &&
+ exec "$GIT_DIR/hooks/commit-msg" ${1+"$@"}
+:
diff --git a/testing/lua-microlight/Microlight.git/hooks/commit-msg.sample b/testing/lua-microlight/Microlight.git/hooks/commit-msg.sample
new file mode 100755
index 0000000000..b58d1184a9
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/hooks/commit-msg.sample
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# An example hook script to check the commit log message.
+# Called by "git commit" with one argument, the name of the file
+# that has the commit message. The hook should exit with non-zero
+# status after issuing an appropriate message if it wants to stop the
+# commit. The hook is allowed to edit the commit message file.
+#
+# To enable this hook, rename this file to "commit-msg".
+
+# Uncomment the below to add a Signed-off-by line to the message.
+# Doing this in a hook is a bad idea in general, but the prepare-commit-msg
+# hook is more suited to it.
+#
+# SOB=$(git var GIT_AUTHOR_IDENT | sed -n 's/^\(.*>\).*$/Signed-off-by: \1/p')
+# grep -qs "^$SOB" "$1" || echo "$SOB" >> "$1"
+
+# This example catches duplicate Signed-off-by lines.
+
+test "" = "$(grep '^Signed-off-by: ' "$1" |
+ sort | uniq -c | sed -e '/^[ ]*1[ ]/d')" || {
+ echo >&2 Duplicate Signed-off-by lines.
+ exit 1
+}
diff --git a/testing/lua-microlight/Microlight.git/hooks/post-update.sample b/testing/lua-microlight/Microlight.git/hooks/post-update.sample
new file mode 100755
index 0000000000..ec17ec1939
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/hooks/post-update.sample
@@ -0,0 +1,8 @@
+#!/bin/sh
+#
+# An example hook script to prepare a packed repository for use over
+# dumb transports.
+#
+# To enable this hook, rename this file to "post-update".
+
+exec git update-server-info
diff --git a/testing/lua-microlight/Microlight.git/hooks/pre-applypatch.sample b/testing/lua-microlight/Microlight.git/hooks/pre-applypatch.sample
new file mode 100755
index 0000000000..b1f187c2e9
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/hooks/pre-applypatch.sample
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# An example hook script to verify what is about to be committed
+# by applypatch from an e-mail message.
+#
+# The hook should exit with non-zero status after issuing an
+# appropriate message if it wants to stop the commit.
+#
+# To enable this hook, rename this file to "pre-applypatch".
+
+. git-sh-setup
+test -x "$GIT_DIR/hooks/pre-commit" &&
+ exec "$GIT_DIR/hooks/pre-commit" ${1+"$@"}
+:
diff --git a/testing/lua-microlight/Microlight.git/hooks/pre-commit.sample b/testing/lua-microlight/Microlight.git/hooks/pre-commit.sample
new file mode 100755
index 0000000000..18c4829765
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/hooks/pre-commit.sample
@@ -0,0 +1,50 @@
+#!/bin/sh
+#
+# An example hook script to verify what is about to be committed.
+# Called by "git commit" with no arguments. The hook should
+# exit with non-zero status after issuing an appropriate message if
+# it wants to stop the commit.
+#
+# To enable this hook, rename this file to "pre-commit".
+
+if git rev-parse --verify HEAD >/dev/null 2>&1
+then
+ against=HEAD
+else
+ # Initial commit: diff against an empty tree object
+ against=4b825dc642cb6eb9a060e54bf8d69288fbee4904
+fi
+
+# If you want to allow non-ascii filenames set this variable to true.
+allownonascii=$(git config hooks.allownonascii)
+
+# Redirect output to stderr.
+exec 1>&2
+
+# Cross platform projects tend to avoid non-ascii filenames; prevent
+# them from being added to the repository. We exploit the fact that the
+# printable range starts at the space character and ends with tilde.
+if [ "$allownonascii" != "true" ] &&
+ # Note that the use of brackets around a tr range is ok here, (it's
+ # even required, for portability to Solaris 10's /usr/bin/tr), since
+ # the square bracket bytes happen to fall in the designated range.
+ test $(git diff --cached --name-only --diff-filter=A -z $against |
+ LC_ALL=C tr -d '[ -~]\0' | wc -c) != 0
+then
+ echo "Error: Attempt to add a non-ascii file name."
+ echo
+ echo "This can cause problems if you want to work"
+ echo "with people on other platforms."
+ echo
+ echo "To be portable it is advisable to rename the file ..."
+ echo
+ echo "If you know what you are doing you can disable this"
+ echo "check using:"
+ echo
+ echo " git config hooks.allownonascii true"
+ echo
+ exit 1
+fi
+
+# If there are whitespace errors, print the offending file names and fail.
+exec git diff-index --check --cached $against --
diff --git a/testing/lua-microlight/Microlight.git/hooks/pre-rebase.sample b/testing/lua-microlight/Microlight.git/hooks/pre-rebase.sample
new file mode 100755
index 0000000000..9773ed4cb2
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/hooks/pre-rebase.sample
@@ -0,0 +1,169 @@
+#!/bin/sh
+#
+# Copyright (c) 2006, 2008 Junio C Hamano
+#
+# The "pre-rebase" hook is run just before "git rebase" starts doing
+# its job, and can prevent the command from running by exiting with
+# non-zero status.
+#
+# The hook is called with the following parameters:
+#
+# $1 -- the upstream the series was forked from.
+# $2 -- the branch being rebased (or empty when rebasing the current branch).
+#
+# This sample shows how to prevent topic branches that are already
+# merged to 'next' branch from getting rebased, because allowing it
+# would result in rebasing already published history.
+
+publish=next
+basebranch="$1"
+if test "$#" = 2
+then
+ topic="refs/heads/$2"
+else
+ topic=`git symbolic-ref HEAD` ||
+ exit 0 ;# we do not interrupt rebasing detached HEAD
+fi
+
+case "$topic" in
+refs/heads/??/*)
+ ;;
+*)
+ exit 0 ;# we do not interrupt others.
+ ;;
+esac
+
+# Now we are dealing with a topic branch being rebased
+# on top of master. Is it OK to rebase it?
+
+# Does the topic really exist?
+git show-ref -q "$topic" || {
+ echo >&2 "No such branch $topic"
+ exit 1
+}
+
+# Is topic fully merged to master?
+not_in_master=`git rev-list --pretty=oneline ^master "$topic"`
+if test -z "$not_in_master"
+then
+ echo >&2 "$topic is fully merged to master; better remove it."
+ exit 1 ;# we could allow it, but there is no point.
+fi
+
+# Is topic ever merged to next? If so you should not be rebasing it.
+only_next_1=`git rev-list ^master "^$topic" ${publish} | sort`
+only_next_2=`git rev-list ^master ${publish} | sort`
+if test "$only_next_1" = "$only_next_2"
+then
+ not_in_topic=`git rev-list "^$topic" master`
+ if test -z "$not_in_topic"
+ then
+ echo >&2 "$topic is already up-to-date with master"
+ exit 1 ;# we could allow it, but there is no point.
+ else
+ exit 0
+ fi
+else
+ not_in_next=`git rev-list --pretty=oneline ^${publish} "$topic"`
+ /usr/bin/perl -e '
+ my $topic = $ARGV[0];
+ my $msg = "* $topic has commits already merged to public branch:\n";
+ my (%not_in_next) = map {
+ /^([0-9a-f]+) /;
+ ($1 => 1);
+ } split(/\n/, $ARGV[1]);
+ for my $elem (map {
+ /^([0-9a-f]+) (.*)$/;
+ [$1 => $2];
+ } split(/\n/, $ARGV[2])) {
+ if (!exists $not_in_next{$elem->[0]}) {
+ if ($msg) {
+ print STDERR $msg;
+ undef $msg;
+ }
+ print STDERR " $elem->[1]\n";
+ }
+ }
+ ' "$topic" "$not_in_next" "$not_in_master"
+ exit 1
+fi
+
+exit 0
+
+################################################################
+
+This sample hook safeguards topic branches that have been
+published from being rewound.
+
+The workflow assumed here is:
+
+ * Once a topic branch forks from "master", "master" is never
+ merged into it again (either directly or indirectly).
+
+ * Once a topic branch is fully cooked and merged into "master",
+ it is deleted. If you need to build on top of it to correct
+ earlier mistakes, a new topic branch is created by forking at
+ the tip of the "master". This is not strictly necessary, but
+ it makes it easier to keep your history simple.
+
+ * Whenever you need to test or publish your changes to topic
+ branches, merge them into "next" branch.
+
+The script, being an example, hardcodes the publish branch name
+to be "next", but it is trivial to make it configurable via
+$GIT_DIR/config mechanism.
+
+With this workflow, you would want to know:
+
+(1) ... if a topic branch has ever been merged to "next". Young
+ topic branches can have stupid mistakes you would rather
+ clean up before publishing, and things that have not been
+ merged into other branches can be easily rebased without
+ affecting other people. But once it is published, you would
+ not want to rewind it.
+
+(2) ... if a topic branch has been fully merged to "master".
+ Then you can delete it. More importantly, you should not
+ build on top of it -- other people may already want to
+ change things related to the topic as patches against your
+ "master", so if you need further changes, it is better to
+ fork the topic (perhaps with the same name) afresh from the
+ tip of "master".
+
+Let's look at this example:
+
+ o---o---o---o---o---o---o---o---o---o "next"
+ / / / /
+ / a---a---b A / /
+ / / / /
+ / / c---c---c---c B /
+ / / / \ /
+ / / / b---b C \ /
+ / / / / \ /
+ ---o---o---o---o---o---o---o---o---o---o---o "master"
+
+
+A, B and C are topic branches.
+
+ * A has one fix since it was merged up to "next".
+
+ * B has finished. It has been fully merged up to "master" and "next",
+ and is ready to be deleted.
+
+ * C has not merged to "next" at all.
+
+We would want to allow C to be rebased, refuse A, and encourage
+B to be deleted.
+
+To compute (1):
+
+ git rev-list ^master ^topic next
+ git rev-list ^master next
+
+ if these match, topic has not merged in next at all.
+
+To compute (2):
+
+ git rev-list master..topic
+
+ if this is empty, it is fully merged to "master".
diff --git a/testing/lua-microlight/Microlight.git/hooks/prepare-commit-msg.sample b/testing/lua-microlight/Microlight.git/hooks/prepare-commit-msg.sample
new file mode 100755
index 0000000000..f093a02ec4
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/hooks/prepare-commit-msg.sample
@@ -0,0 +1,36 @@
+#!/bin/sh
+#
+# An example hook script to prepare the commit log message.
+# Called by "git commit" with the name of the file that has the
+# commit message, followed by the description of the commit
+# message's source. The hook's purpose is to edit the commit
+# message file. If the hook fails with a non-zero status,
+# the commit is aborted.
+#
+# To enable this hook, rename this file to "prepare-commit-msg".
+
+# This hook includes three examples. The first comments out the
+# "Conflicts:" part of a merge commit.
+#
+# The second includes the output of "git diff --name-status -r"
+# into the message, just before the "git status" output. It is
+# commented because it doesn't cope with --amend or with squashed
+# commits.
+#
+# The third example adds a Signed-off-by line to the message, that can
+# still be edited. This is rarely a good idea.
+
+case "$2,$3" in
+ merge,)
+ /usr/bin/perl -i.bak -ne 's/^/# /, s/^# #/#/ if /^Conflicts/ .. /#/; print' "$1" ;;
+
+# ,|template,)
+# /usr/bin/perl -i.bak -pe '
+# print "\n" . `git diff --cached --name-status -r`
+# if /^#/ && $first++ == 0' "$1" ;;
+
+ *) ;;
+esac
+
+# SOB=$(git var GIT_AUTHOR_IDENT | sed -n 's/^\(.*>\).*$/Signed-off-by: \1/p')
+# grep -qs "^$SOB" "$1" || echo "$SOB" >> "$1"
diff --git a/testing/lua-microlight/Microlight.git/hooks/update.sample b/testing/lua-microlight/Microlight.git/hooks/update.sample
new file mode 100755
index 0000000000..71ab04edc0
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/hooks/update.sample
@@ -0,0 +1,128 @@
+#!/bin/sh
+#
+# An example hook script to blocks unannotated tags from entering.
+# Called by "git receive-pack" with arguments: refname sha1-old sha1-new
+#
+# To enable this hook, rename this file to "update".
+#
+# Config
+# ------
+# hooks.allowunannotated
+# This boolean sets whether unannotated tags will be allowed into the
+# repository. By default they won't be.
+# hooks.allowdeletetag
+# This boolean sets whether deleting tags will be allowed in the
+# repository. By default they won't be.
+# hooks.allowmodifytag
+# This boolean sets whether a tag may be modified after creation. By default
+# it won't be.
+# hooks.allowdeletebranch
+# This boolean sets whether deleting branches will be allowed in the
+# repository. By default they won't be.
+# hooks.denycreatebranch
+# This boolean sets whether remotely creating branches will be denied
+# in the repository. By default this is allowed.
+#
+
+# --- Command line
+refname="$1"
+oldrev="$2"
+newrev="$3"
+
+# --- Safety check
+if [ -z "$GIT_DIR" ]; then
+ echo "Don't run this script from the command line." >&2
+ echo " (if you want, you could supply GIT_DIR then run" >&2
+ echo " $0 <ref> <oldrev> <newrev>)" >&2
+ exit 1
+fi
+
+if [ -z "$refname" -o -z "$oldrev" -o -z "$newrev" ]; then
+ echo "Usage: $0 <ref> <oldrev> <newrev>" >&2
+ exit 1
+fi
+
+# --- Config
+allowunannotated=$(git config --bool hooks.allowunannotated)
+allowdeletebranch=$(git config --bool hooks.allowdeletebranch)
+denycreatebranch=$(git config --bool hooks.denycreatebranch)
+allowdeletetag=$(git config --bool hooks.allowdeletetag)
+allowmodifytag=$(git config --bool hooks.allowmodifytag)
+
+# check for no description
+projectdesc=$(sed -e '1q' "$GIT_DIR/description")
+case "$projectdesc" in
+"Unnamed repository"* | "")
+ echo "*** Project description file hasn't been set" >&2
+ exit 1
+ ;;
+esac
+
+# --- Check types
+# if $newrev is 0000...0000, it's a commit to delete a ref.
+zero="0000000000000000000000000000000000000000"
+if [ "$newrev" = "$zero" ]; then
+ newrev_type=delete
+else
+ newrev_type=$(git cat-file -t $newrev)
+fi
+
+case "$refname","$newrev_type" in
+ refs/tags/*,commit)
+ # un-annotated tag
+ short_refname=${refname##refs/tags/}
+ if [ "$allowunannotated" != "true" ]; then
+ echo "*** The un-annotated tag, $short_refname, is not allowed in this repository" >&2
+ echo "*** Use 'git tag [ -a | -s ]' for tags you want to propagate." >&2
+ exit 1
+ fi
+ ;;
+ refs/tags/*,delete)
+ # delete tag
+ if [ "$allowdeletetag" != "true" ]; then
+ echo "*** Deleting a tag is not allowed in this repository" >&2
+ exit 1
+ fi
+ ;;
+ refs/tags/*,tag)
+ # annotated tag
+ if [ "$allowmodifytag" != "true" ] && git rev-parse $refname > /dev/null 2>&1
+ then
+ echo "*** Tag '$refname' already exists." >&2
+ echo "*** Modifying a tag is not allowed in this repository." >&2
+ exit 1
+ fi
+ ;;
+ refs/heads/*,commit)
+ # branch
+ if [ "$oldrev" = "$zero" -a "$denycreatebranch" = "true" ]; then
+ echo "*** Creating a branch is not allowed in this repository" >&2
+ exit 1
+ fi
+ ;;
+ refs/heads/*,delete)
+ # delete branch
+ if [ "$allowdeletebranch" != "true" ]; then
+ echo "*** Deleting a branch is not allowed in this repository" >&2
+ exit 1
+ fi
+ ;;
+ refs/remotes/*,commit)
+ # tracking branch
+ ;;
+ refs/remotes/*,delete)
+ # delete tracking branch
+ if [ "$allowdeletebranch" != "true" ]; then
+ echo "*** Deleting a tracking branch is not allowed in this repository" >&2
+ exit 1
+ fi
+ ;;
+ *)
+ # Anything else (is there anything else?)
+ echo "*** Update hook: unknown type of update to ref $refname of type $newrev_type" >&2
+ exit 1
+ ;;
+esac
+
+# --- Finished
+exit 0
diff --git a/testing/lua-microlight/Microlight.git/info/exclude b/testing/lua-microlight/Microlight.git/info/exclude
new file mode 100644
index 0000000000..a5196d1be8
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/info/exclude
@@ -0,0 +1,6 @@
+# git ls-files --others --exclude-from=.git/info/exclude
+# Lines that start with '#' are comments.
+# For a project mostly in C, the following would be a good set of
+# exclude patterns (uncomment them if you want to use them):
+# *.[oa]
+# *~
diff --git a/testing/lua-microlight/Microlight.git/objects/pack/pack-b24eeb410b7f82331a4c067294ec2b9bd38f24ed.idx b/testing/lua-microlight/Microlight.git/objects/pack/pack-b24eeb410b7f82331a4c067294ec2b9bd38f24ed.idx
new file mode 100644
index 0000000000..de1588edb9
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/objects/pack/pack-b24eeb410b7f82331a4c067294ec2b9bd38f24ed.idx
Binary files differ
diff --git a/testing/lua-microlight/Microlight.git/objects/pack/pack-b24eeb410b7f82331a4c067294ec2b9bd38f24ed.pack b/testing/lua-microlight/Microlight.git/objects/pack/pack-b24eeb410b7f82331a4c067294ec2b9bd38f24ed.pack
new file mode 100644
index 0000000000..72427db2a8
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/objects/pack/pack-b24eeb410b7f82331a4c067294ec2b9bd38f24ed.pack
Binary files differ
diff --git a/testing/lua-microlight/Microlight.git/packed-refs b/testing/lua-microlight/Microlight.git/packed-refs
new file mode 100644
index 0000000000..3e29ec8c06
--- /dev/null
+++ b/testing/lua-microlight/Microlight.git/packed-refs
@@ -0,0 +1,2 @@
+# pack-refs with: peeled
+dac3b125c5276ade4384eb95b40ec8d501a043ec refs/heads/master
diff --git a/testing/lua-microlight/lua-microlight.tar b/testing/lua-microlight/lua-microlight.tar
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/testing/lua-microlight/lua-microlight.tar