summaryrefslogtreecommitdiffstats
path: root/testing/mplayer2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-05 20:06:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-05 20:06:07 +0000
commitf14e4c01b3f3edd4fbec8d31d6d1b408d619ba9a (patch)
treeb54f89f14e02ebdedd7546f51f9b70ac42b99874 /testing/mplayer2
parent1a18eedab790a4b740e43722ae4afac46b4f310e (diff)
downloadaports-fcolista-f14e4c01b3f3edd4fbec8d31d6d1b408d619ba9a.tar.bz2
aports-fcolista-f14e4c01b3f3edd4fbec8d31d6d1b408d619ba9a.tar.xz
testing/mplayer2: new aport
advanced general-purpose video player http://www.mplayer2.org/
Diffstat (limited to 'testing/mplayer2')
-rw-r--r--testing/mplayer2/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/mplayer2/APKBUILD b/testing/mplayer2/APKBUILD
new file mode 100644
index 0000000000..d768e1a92e
--- /dev/null
+++ b/testing/mplayer2/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mplayer2
+pkgver=2.0
+pkgrel=0
+pkgdesc="advanced general-purpose video player"
+url="http://www.mplayer2.org/"
+arch="all"
+license="GPL"
+depends=
+makedepends="libxxf86dga-dev libxv-dev libmad-dev lame-dev libao-dev
+ libtheora-dev xvidcore-dev zlib-dev sdl-dev freetype-dev
+ x264-dev faac-dev ttf-dejavu libxvmc-dev alsa-lib-dev live-media-dev
+ mesa-dev ffmpeg-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://ftp.mplayer2.org/pub/release/mplayer2-$pkgver.tar.xz"
+
+_builddir="$srcdir"/mplayer2-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/mplayer2 \
+ --confdir=/etc/mplayer2 \
+ --enable-runtime-cpudetection \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ mv "$pkgdir"/usr/bin/mplayer "$pkgdir"/usr/bin/mplayer2
+}
+
+md5sums="b880ae4be0e5b9693cdecf97c84b74f3 mplayer2-2.0.tar.xz"