summaryrefslogtreecommitdiffstats
path: root/testing/openxcap
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-05-20 06:22:36 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-05-20 10:03:47 +0000
commit96ee98c664e964f813ea011974413a2fcf0c516d (patch)
treec50dfc811a066906c6372297a53c30db31fd7ab0 /testing/openxcap
parent40446c186e93955efa055fb9dade491966e1cfe5 (diff)
downloadaports-fcolista-96ee98c664e964f813ea011974413a2fcf0c516d.tar.bz2
aports-fcolista-96ee98c664e964f813ea011974413a2fcf0c516d.tar.xz
testing/openxcap: new aport
Diffstat (limited to 'testing/openxcap')
-rw-r--r--testing/openxcap/APKBUILD36
-rw-r--r--testing/openxcap/config.ini118
-rw-r--r--testing/openxcap/openxcap.initd23
3 files changed, 177 insertions, 0 deletions
diff --git a/testing/openxcap/APKBUILD b/testing/openxcap/APKBUILD
new file mode 100644
index 0000000000..c065028385
--- /dev/null
+++ b/testing/openxcap/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+
+pkgname=openxcap
+pkgver=1.2.0
+pkgrel=2
+pkgdesc="Open source fully featured XCAP server "
+url="http://openxcap.org"
+pkgusers="openxcap"
+pkggroups="openxcap"
+license="GPL"
+depends="python python-application python-gnutls twisted twisted-web2 python-imaging python-lxml python-mysqldb"
+makedepends="python-dev"
+install="$pkgname.pre-install $pkgname.post-install"
+source="http://download.ag-projects.com/XCAP/$pkgname-$pkgver.tar.gz
+ config.ini
+ openxcap.initd
+"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
+
+ python setup.py install --root="$pkgdir" || return 1
+
+ echo "/usr/lib/python2.6/site-packages/$pkgname-$pkgver-py2.6.egg" \
+ > "$pkgdir"/usr/lib/python2.6/site-packages/$pkgname.pth
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -d -o openxcap "$pkgdir"/var/run/openxcap
+}
+
+md5sums="ec34570deee2019a1ebf9a012a476c26 openxcap-1.2.0.tar.gz
+7a18872843586717eaf3879444cc13d2 config.ini
+dad5f337c29c9e245846d9991d057b6e openxcap.initd"
diff --git a/testing/openxcap/config.ini b/testing/openxcap/config.ini
new file mode 100644
index 0000000000..bcf5b22f23
--- /dev/null
+++ b/testing/openxcap/config.ini
@@ -0,0 +1,118 @@
+;
+; Configuration file for OpenXCAP
+;
+; The values in the commented lines represent the defaults built in the
+; server software
+;
+[Server]
+
+; IP address to listen for requests
+; 0.0.0.0 means any address of this host
+
+; address = 0.0.0.0
+
+; This is a comma separated list of XCAP root URIs. The first is the
+; primary XCAP root URI, while the others (if specified) are aliases.
+; The primary root URI is used when generating xcap-diff
+; If the scheme is https, then the server will listen for requests in TLS mode.
+
+root = http://xcap.example.com/xcap-root
+
+; The backend to be used for storage and authentication. Current supported
+; values are Database and OpenSIPS. OpenSIPS backend inherits all the settings
+; from the Database backend but performs extra actions related to the
+; integration with OpenSIPS for which it read the settings from [OpenSIPS]
+; section
+
+backend = OpenSIPS
+
+; Validate XCAP documents against XML schemas
+
+; document_validation = Yes
+
+
+[Logging]
+
+; Start, stop and major server error messages are always logged to syslog.
+
+; This section can be used to log more details about XCAP clients accessing
+; the server. The values in the commented lines represent the defaults built
+; in the server software
+
+; Directory where to write access.log file that will contain requests and/or
+; responses to OpenXCAP server in Apache style. If set to an empty string,
+; access logs will be printed to stdout if the server runs in no-fork mode
+; or to syslog if the server runs in the background
+
+; directory=/var/log/openxcap
+
+; The following parameters control what kind of information (like
+; stacktrace, body or headers) is logged for which response codes. The
+; values must be a comma-separated list of HTTP response codes or the
+; keyword 'any' that matches all response codes.
+
+; log_stacktrace=500
+; log_response_headers=500
+; log_response_body=500
+; log_request_headers=500
+; log_request_body=500
+
+
+[Authentication]
+
+; The HTTP authentication type, this can be either 'basic' or 'digest'. The
+; standard states 'digest' as the mandatory, however it can be changed to
+; basic
+
+; type = digest
+
+; Specify if the passwords are stored as plain text - Yes
+; or in a hashed format MD5('username:domain:password') - No
+; cleartext_passwords = Yes
+
+; The default authentication realm, if none indicated in the HTTP request
+; URI
+default_realm = example.com
+
+; A comma-separated list of hosts or networks to trust.
+; The elements can be an IP address in CIDR format, a
+; hostname or an IP address (in the latter 2 a mask of 32
+; is assumed), or the special keywords 'any' and 'none'
+; (being equivalent to 0.0.0.0/0 and 0.0.0.0/32
+; respectively).
+; trusted_peers =
+
+
+[TLS]
+
+; Location of X509 certificate and private key that identify this server.
+; The path is relative to /etc/openxcap, or it can be given as an absolute
+; path.
+
+; Server X509 certificate
+; certificate =
+
+; Server X509 private key
+; private_key =
+
+
+[Database]
+
+; The database connection URI for the datase with subscriber accounts
+authentication_db_uri = pgsql://username:password@db/opensips
+
+; The database connection URI for the database that stores the XCAP documents
+storage_db_uri = mysql://username:password@db/opensips
+
+; Authentication and storage tables
+; subscriber_table = subscriber
+; xcap_table = xcap
+
+
+[OpenSIPS]
+
+; The address and port of the xml-rpc management interface
+xmlrpc_url = http://sip.example.com:8080
+
+; Publish xcap-diff event via OpenSIPS management interface
+; enable_publish_xcapdiff = yes
diff --git a/testing/openxcap/openxcap.initd b/testing/openxcap/openxcap.initd
new file mode 100644
index 0000000000..e58a77926d
--- /dev/null
+++ b/testing/openxcap/openxcap.initd
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+#
+
+daemon=/usr/bin/openxcap
+pidfile=/var/run/openxcap/openxcap.pid"
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting OpenXCAP Presence Server"
+ start-stop-daemon --start --quiet --pidfile $pidfile --exec $daemon
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping OpenXCAP Presence Server"
+ start-stop-daemon --stop --quiet --signal 15 --pidfile $pidfile
+ eend $?
+}
+