summaryrefslogtreecommitdiffstats
path: root/testing/py-mechanize
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-18 16:49:25 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-20 16:57:43 +0000
commit0b227bf321b5f0904ace50333f9d1ff887ad9a7e (patch)
tree627670a14d3e2d198bf46fdff9e2477b6e2e33a0 /testing/py-mechanize
parentc6d3cb24641222f87bdf918dd69c713c1157f83b (diff)
downloadaports-fcolista-0b227bf321b5f0904ace50333f9d1ff887ad9a7e.tar.bz2
aports-fcolista-0b227bf321b5f0904ace50333f9d1ff887ad9a7e.tar.xz
testing/py-mechanize: upgrade to 0.2.5
Diffstat (limited to 'testing/py-mechanize')
-rw-r--r--testing/py-mechanize/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/testing/py-mechanize/APKBUILD b/testing/py-mechanize/APKBUILD
index 0fdad0c25b..c7c661a271 100644
--- a/testing/py-mechanize/APKBUILD
+++ b/testing/py-mechanize/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer:
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-mechanize
_pkgname=mechanize
-pkgver=0.2.4
+pkgver=0.2.5
pkgrel=0
pkgdesc="Stateful programmatic web browsing in Python"
url="http://wwwsearch.sourceforge.net/mechanize/"
@@ -15,9 +15,16 @@ install=""
subpackages=""
source="http://wwwsearch.sourceforge.net/$_pkgname/src/$_pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
package() {
cd "$_builddir"
- python setup.py install --root=$pkgdir
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
install -Dm644 COPYING.txt ${pkgdir}/usr/share/licenses/custom/${pkgname}/COPYING.txt
}
-md5sums="0c1c3cec1c6d7b5d87662a069f04eb8d mechanize-0.2.4.tar.gz"
+
+md5sums="32657f139fc2fb75bcf193b63b8c60b2 mechanize-0.2.5.tar.gz"