summaryrefslogtreecommitdiffstats
path: root/testing/py-simplejson
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-11-05 13:54:42 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-11-05 13:54:42 +0000
commitb125d0fbc8d043d54a7838adcb32468f3ff6da3e (patch)
tree01294b298e804771d5326e8a2c268005bd191f71 /testing/py-simplejson
parent157b3eb3b425a8c159d548d6528c1e19197eae32 (diff)
downloadaports-fcolista-b125d0fbc8d043d54a7838adcb32468f3ff6da3e.tar.bz2
aports-fcolista-b125d0fbc8d043d54a7838adcb32468f3ff6da3e.tar.xz
testing/py-simplejson: new aport
Diffstat (limited to 'testing/py-simplejson')
-rw-r--r--testing/py-simplejson/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py-simplejson/APKBUILD b/testing/py-simplejson/APKBUILD
new file mode 100644
index 0000000000..dc357fafbc
--- /dev/null
+++ b/testing/py-simplejson/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-simplejson
+_name=simplejson
+pkgver=2.6.2
+pkgrel=0
+pkgdesc="Simple, fast, extensible JSON encoder/decoder for Python"
+url="http://pypi.python.org/pypi/simplejson/"
+arch="all"
+license="PSF"
+depends=""
+depends_dev="python-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/s/simplejson/simplejson-2.6.2.tar.gz"
+_builddir=${srcdir}/${_name}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir"
+}
+
+md5sums="9b41cd412dfac7c002aeca61ab0fdfe2 simplejson-2.6.2.tar.gz"