summaryrefslogtreecommitdiffstats
path: root/testing/python3
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-06-23 09:32:02 -0400
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-06-23 09:33:08 -0400
commit02cb2292b4791f81f5d367ea4688745d4d105b93 (patch)
treea889c91326d486d5282387454ac1253ed4ef7698 /testing/python3
parent252d686c7d892c64ff387d9335235a8a8bb91d6b (diff)
downloadaports-fcolista-02cb2292b4791f81f5d367ea4688745d4d105b93.tar.bz2
aports-fcolista-02cb2292b4791f81f5d367ea4688745d4d105b93.tar.xz
testing/python3: Upgrade to 3.2.0, now with working python3-tests subpkg.
Diffstat (limited to 'testing/python3')
-rw-r--r--testing/python3/APKBUILD43
1 files changed, 24 insertions, 19 deletions
diff --git a/testing/python3/APKBUILD b/testing/python3/APKBUILD
index c3cc5477ad..489562fc39 100644
--- a/testing/python3/APKBUILD
+++ b/testing/python3/APKBUILD
@@ -1,19 +1,21 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=python3
-pkgver=3.1.3
+pkgver=3.2.0
+_pkgver=3.2
pkgrel=0
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
license="custom"
-subpackages="$pkgname-dev $pkgname-doc" #$pkgname-tests"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tests"
depends=
makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev
sqlite-dev libffi-dev tcl-dev"
-source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.bz2"
+source="http://www.python.org/ftp/python/$_pkgver/Python-$_pkgver.tar.bz2"
+_builddir="$srcdir"/Python-$_pkgver
build() {
- cd "$srcdir/Python-$pkgver"
+ cd "$_builddir"
./configure --prefix=/usr \
--enable-shared \
--with-threads \
@@ -26,24 +28,27 @@ build() {
}
package() {
- cd "$srcdir/Python-$pkgver"
+ cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install
mv "$pkgdir"/usr/bin/2to3 "$pkgdir"/usr/bin/2to3-3.1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-#_mv_files() {
-# local i
-# for i in "$@"; do
-# mkdir -p "$subpkgdir"/${i%/*}
-# mv -f "$pkgdir"/$i "$subpkgdir"/$i || return 1
-# done
-#}
-#
-#tests() {
-# pkgdesc="The test modules from the main python package"
-# cd "$pkgdir"
-# _mv_files $(find usr/lib -type d -name 'test*')
-#}
+_mv_files() {
+ cd "$pkgdir"/usr/lib/python$_pkgver
+ for i in */test */tests; do
+ mkdir -p "$subpkgdir"/usr/lib/python$_pkgver/"$i"
+ mv "$i"/* "$subpkgdir"/usr/lib/python$_pkgver/"$i"
+ rm -rf "$i"
+ done
+ mv "$pkgdir"/usr/lib/python$_pkgver/test "$subpkgdir"/usr/lib/python$_pkgver
+}
+
+tests() {
+ pkgdesc="The test modules from the main python package"
+ arch="noarch"
+ cd "$pkgdir"
+ _mv_files
+}
-md5sums="ad5e5f1c07e829321e0a015f8cafe245 Python-3.1.3.tar.bz2"
+md5sums="92e94b5b6652b96349d6362b8337811d Python-3.2.tar.bz2"