summaryrefslogtreecommitdiffstats
path: root/testing/rutorrent
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-12-24 12:21:13 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-12-24 12:21:13 +0000
commitbd023fa429a785773bb0e55732590e79e74ad2e7 (patch)
tree3417ffdddb3ab8394f1bc1c3f2d3367d974ae4b0 /testing/rutorrent
parent3a6898cfc8ab0162e868bf1892ab4f2e4fa9ae5f (diff)
downloadaports-fcolista-bd023fa429a785773bb0e55732590e79e74ad2e7.tar.bz2
aports-fcolista-bd023fa429a785773bb0e55732590e79e74ad2e7.tar.xz
testing/rutorrent: new aport. Fixes #1466
Diffstat (limited to 'testing/rutorrent')
-rw-r--r--testing/rutorrent/APKBUILD34
-rw-r--r--testing/rutorrent/rutorrent.post-install26
-rw-r--r--testing/rutorrent/rutorrent.pre-install4
3 files changed, 64 insertions, 0 deletions
diff --git a/testing/rutorrent/APKBUILD b/testing/rutorrent/APKBUILD
new file mode 100644
index 0000000000..792ff332d0
--- /dev/null
+++ b/testing/rutorrent/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=rutorrent
+pkgver=3.5
+pkgrel=0
+pkgdesc="Yet another web front-end for rTorrent"
+url="http://code.google.com/p/rutorrent/"
+arch="noarch"
+license="GPL"
+depends="php curl gzip coreutils"
+depends_dev=""
+makedepends=""
+pkggroups="rutorrent"
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages=""
+source="http://rutorrent.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ install -d $pkgdir/usr/share/webapps/$pkgname
+ install -d $pkgdir/var/www/localhost/htdocs/
+ cp -r * $pkgdir/usr/share/webapps/$pkgname
+ chgrp -R rutorrent $pkgdir/usr/share/webapps/$pkgname/share
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/settings
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/torrents
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
+}
+
+md5sums="210cbabe0ead88c865c654bab2109e92 rutorrent-3.5.tar.gz"
diff --git a/testing/rutorrent/rutorrent.post-install b/testing/rutorrent/rutorrent.post-install
new file mode 100644
index 0000000000..05ce03e90c
--- /dev/null
+++ b/testing/rutorrent/rutorrent.post-install
@@ -0,0 +1,26 @@
+#!/bin/sh
+ln -s /usr/share/webapps/rutorrent /var/www/localhost/htdocs/rutorrent 2>/dev/null
+echo "*" >&2
+echo "* rutorrent has been installed to: " >&2
+echo "* /usr/share/webapps/rutorrent " >&2
+echo "* If you use lighttpd: " >&2
+echo "* 1 - enable mod_scgi in lighttpd.conf adding: " >&2
+echo "* server.modules += ( "mod_scgi" ) " >&2
+echo "* 2 - touch /etc/lighttpd/mod_scgi.conf " >&2
+echo "* 3 - add the following entry in mod_scgi.conf: " >&2
+echo "* scgi.server =( " >&2
+echo "* "/RPC1" => " >&2
+echo "* ( "127.0.0.1" => " >&2
+echo "* ( " >&2
+echo "* "host" => "127.0.0.1", " >&2
+echo "* "port" => 5000, " >&2
+echo "* "check-local" => "disable" " >&2
+echo "* ) " >&2
+echo "* ) " >&2
+echo "* ) " >&2
+echo "* 4 - (optional) Add lighttpd to rutorrent group " >&2
+echo "* to give to webserver r/w permissions on rutorrent " >&2
+echo "* share folder (/usr/share/webapps/rutorrent/share): " >&2
+echo "* addgroup lighttpd rutorrent " >&2
+echo "*" >&2
+exit 0
diff --git a/testing/rutorrent/rutorrent.pre-install b/testing/rutorrent/rutorrent.pre-install
new file mode 100644
index 0000000000..2d0c909c31
--- /dev/null
+++ b/testing/rutorrent/rutorrent.pre-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+addgroup rutorrent 2>/dev/null
+exit 0
+