summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-15 15:13:19 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-15 15:13:19 +0100
commit1b10a8d0ea1c5603c1621f26b6d2c0c8312bc1c9 (patch)
treee89656846cd415c9f51275b2e232a64a16858e82 /testing
parent6c615833a557fdda19e2ffdc46dfdbb0486a3901 (diff)
downloadaports-fcolista-1b10a8d0ea1c5603c1621f26b6d2c0c8312bc1c9.tar.bz2
aports-fcolista-1b10a8d0ea1c5603c1621f26b6d2c0c8312bc1c9.tar.xz
testing/dev86: build fix for x86_64
patch from fedora
Diffstat (limited to 'testing')
-rw-r--r--testing/dev86/APKBUILD4
-rw-r--r--testing/dev86/dev86-long.patch17
2 files changed, 20 insertions, 1 deletions
diff --git a/testing/dev86/APKBUILD b/testing/dev86/APKBUILD
index dd1ab2139e..84a08e4246 100644
--- a/testing/dev86/APKBUILD
+++ b/testing/dev86/APKBUILD
@@ -16,6 +16,7 @@ source="http://www.debath.co.uk/dev86/Dev86src-$pkgver.tar.gz
dev86-pic.patch
dev86-overflow.patch
dev86-print-overflow.patch
+ dev86-long.patch
"
_builddir="$srcdir"/dev86-$pkgver
@@ -76,4 +77,5 @@ md5sums="f2e06b547397383b2b2650b9c4fd9bab Dev86src-0.16.18.tar.gz
eba7081bc5dbd72b7b9b902275251499 dev86-noelks.patch
d508a2a8ededa9e34dbd9105dfd66290 dev86-pic.patch
8f462d57fe4d5c9393331ba917db0258 dev86-overflow.patch
-7ce097efcb8c043727b4b3bf6c396c75 dev86-print-overflow.patch"
+7ce097efcb8c043727b4b3bf6c396c75 dev86-print-overflow.patch
+cad5918764234a9ab0492147a336d437 dev86-long.patch"
diff --git a/testing/dev86/dev86-long.patch b/testing/dev86/dev86-long.patch
new file mode 100644
index 0000000000..34cde195bc
--- /dev/null
+++ b/testing/dev86/dev86-long.patch
@@ -0,0 +1,17 @@
+diff -up dev86-0.16.17/ld/x86_aout.h.long dev86-0.16.17/ld/x86_aout.h
+--- dev86-0.16.17/ld/x86_aout.h.long 2003-01-28 23:17:14.000000000 +0100
++++ dev86-0.16.17/ld/x86_aout.h 2009-02-19 11:37:10.000000000 +0100
+@@ -11,10 +11,11 @@
+ /* If the host isn't an x86 all bets are off, use chars. */
+ #if defined(i386) || defined(__BCC__) || defined(MSDOS)
+ typedef long Long;
+-#define __OUT_OK 1
+ #else
+-typedef char Long[4];
++#include <stdint.h>
++typedef int32_t Long;
+ #endif
++#define __OUT_OK 1
+
+ struct exec { /* a.out header */
+ unsigned char a_magic[2]; /* magic number */