summaryrefslogtreecommitdiffstats
path: root/testing/py-acl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-acl/APKBUILD')
-rw-r--r--testing/py-acl/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-acl/APKBUILD b/testing/py-acl/APKBUILD
new file mode 100644
index 0000000000..23a6ff3b23
--- /dev/null
+++ b/testing/py-acl/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-acl
+_pkgname=acl
+pkgver=0.2
+pkgrel=0
+pkgdesc="A python network access control list parsing library"
+url="https://github.com/jathanism/acl"
+arch="noarch"
+license="Apache2"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b86adc869292e0fa29f29e78dc33ae8a acl-0.2.tar.gz"
+sha256sums="30c7257ace2f3b607ba64f1bdf5114af57f3ea191481d77bc985386c8bdef048 acl-0.2.tar.gz"
+sha512sums="7307fcc13ed888d137ff26d960a465b44ca6d43a8aa591c1eb7e37a3e3612cf079c428204a36dc9293fff98e84cc96f139da04bb179e87f5fa545bed4c20c717 acl-0.2.tar.gz"