summaryrefslogtreecommitdiffstats
path: root/testing/py-netifaces/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-netifaces/APKBUILD')
-rw-r--r--testing/py-netifaces/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py-netifaces/APKBUILD b/testing/py-netifaces/APKBUILD
index 332c9196a8..1486d054fb 100644
--- a/testing/py-netifaces/APKBUILD
+++ b/testing/py-netifaces/APKBUILD
@@ -2,15 +2,15 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=py-netifaces
_pkgname=netifaces
-pkgver=0.6
+pkgver=0.8
pkgrel=0
pkgdesc="Portable module to access network interface information in Python"
url="http://alastairs-place.net/netifaces/"
arch="all"
license="MIT"
depends=""
-depends_dev="python-dev py-setuptools"
-makedepends="$depends_dev"
+depends_dev=""
+makedepends="python-dev py-setuptools"
install=""
subpackages="$pkgname-doc"
source="http://alastairs-place.net/projects/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -27,12 +27,15 @@ prepare() {
build() {
cd "$_builddir"
- python setup.py install --root "${pkgdir}"
+ python setup.py build || return 1
}
package() {
cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
install -Dm644 README "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-md5sums="6ea1e045ebd5db99dd675178e41307e5 netifaces-0.6.tar.gz"
+md5sums="e57e5983f4c286fac5f8068fbfc5c873 netifaces-0.8.tar.gz"
+sha256sums="53a711038db3d6e5cf7129d6f751185fd052f830f12f271fbfe17bd2671ab1ec netifaces-0.8.tar.gz"
+sha512sums="b3735c4f83d4ed1d52f59937187659f148205a721fd05ce5a10e9ec89ea3519971001b2985e24bb30fb112ee741310babd847f84d4c3fbb34989edc6a743f551 netifaces-0.8.tar.gz"