summaryrefslogtreecommitdiffstats
path: root/testing/py-twisted-conch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-twisted-conch/APKBUILD')
-rw-r--r--testing/py-twisted-conch/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/py-twisted-conch/APKBUILD b/testing/py-twisted-conch/APKBUILD
new file mode 100644
index 0000000000..49503e740f
--- /dev/null
+++ b/testing/py-twisted-conch/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-twisted-conch
+pkgver=12.2.0
+pkgrel=0
+pkgdesc="SSH and SFTP protocol implementation together with clients and servers"
+url="http://twistedmatrix.com/trac/wiki/TwistedConch"
+arch="noarch"
+license="MIT"
+depends="py-twisted py-crypto py-asn1"
+makedepends="python-dev"
+source="http://twistedmatrix.com/Releases/Conch/${pkgver%.*}/TwistedConch-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/TwistedConch-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a8f07749465eb7c514c9cce0ea4dcfb0 TwistedConch-12.2.0.tar.bz2"
+sha256sums="2d1d6d4dcf8a6c9fd7f7c03e74111049566618765f93fae1da999643caf13cd2 TwistedConch-12.2.0.tar.bz2"
+sha512sums="6b81ed588aeb568e14ad341530ebceabd34e3025da612aa54effe0ff96ff6c20c466b296795209b6ee761890d27f26075915de114459dbc84547587444520da9 TwistedConch-12.2.0.tar.bz2"