summaryrefslogtreecommitdiffstats
path: root/testing/stunnel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/stunnel/APKBUILD')
-rw-r--r--testing/stunnel/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/stunnel/APKBUILD b/testing/stunnel/APKBUILD
new file mode 100644
index 0000000000..59f1478efc
--- /dev/null
+++ b/testing/stunnel/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Dean Takemori <deant@hawaii.rr.com>
+# Maintainer:
+pkgname=stunnel
+pkgver=4.53
+pkgrel=0
+pkgdesc="SSL encryption wrapper between network client and server."
+url="http://www.stunnel.org/"
+arch="all"
+license="GPL2+ with OpenSSL exception"
+depends="openssl"
+depends_dev="openssl-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-doc"
+install=""
+source="ftp://ftp.stunnel.org/stunnel/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 tools/stunnel.license \
+ "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+
+ rm -f "$pkgdir"/usr/lib/stunnel/*.la
+}
+
+md5sums="ab3bfc915357d67da18c73f73610d593 stunnel-4.53.tar.gz"