summaryrefslogtreecommitdiffstats
path: root/testing/util-vserver/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/util-vserver/APKBUILD')
-rw-r--r--testing/util-vserver/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/testing/util-vserver/APKBUILD b/testing/util-vserver/APKBUILD
index 92faf45798..f66a5355ba 100644
--- a/testing/util-vserver/APKBUILD
+++ b/testing/util-vserver/APKBUILD
@@ -2,11 +2,11 @@
pkgname=util-vserver
pkgver=0.30.216_pre2849
_realver=0.30.216-pre2849
-pkgrel=3
+pkgrel=4
pkgdesc="Linux-VServer admin utilities"
url="http://www.nongnu.org/util-vserver/"
license="GPL"
-# needs coreutils for touch -t
+install="$pkgname.post-install $pkgname.post-upgrade"
makedepends="iptables-dev e2fsprogs-dev beecrypt-dev autoconf automake
pkgconfig libtool"
depends="bash make"
@@ -22,9 +22,11 @@ source="http://people.linux-vserver.org/~dhozac/t/uv-testing/util-vserver-$_real
"
subpackages="$pkgname-doc $pkgname-dev"
+_builddir="$srcdir"/$pkgname-$_realver
+
build() {
local i
- cd "$srcdir"/$pkgname-$_realver
+ cd "$_builddir"
for i in ../*.patch; do
[ -r "$i" ] || continue
msg "Applying $i"
@@ -46,6 +48,10 @@ build() {
# use busybox ionice rather than util-linux-ng
sed -i -e 's:/usr/bin/ionice:/bin/ionice:' Makefile
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir/" install install-distribution
install -Dm755 ../setup-vs-template "$pkgdir"/usr/sbin/setup-vs-template
install -Dm755 ../setup-vs-guest "$pkgdir"/usr/sbin/setup-vs-guest
@@ -58,4 +64,4 @@ ff8f561f672524eb46fe633f584ef60e ensc_pathprog.patch
da8b70c4fd40e68894b3903ffd121397 validate.patch
04000261fd990a3963b0e98260b481bd alpine.patch
49bca7969cc284adf68e0ef284c0660e setup-vs-template
-b7a30afd4ba87968cb58137d59d8e8f8 setup-vs-guest"
+838511f74983453ef9827ed875b70d59 setup-vs-guest"