summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-07-27 11:24:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-27 11:28:53 +0000
commit13b2d83cf8aff5bf1acfa4179db677fa7c1a154b (patch)
tree58c282a5763aac6c8c0449d529d4787f106530fa
parentea4043fbfa71b2a5e0f9f43fb84dd7fda4344f27 (diff)
downloadaports-13b2d83cf8aff5bf1acfa4179db677fa7c1a154b.tar.bz2
aports-13b2d83cf8aff5bf1acfa4179db677fa7c1a154b.tar.xz
main/pkgconf: delete the pkg-config symlink
We do not want completely replace pkg-config til we are more or less sure that all package can build with it. For now, to test pkgconf we should use: export PKG_CONFIG=pkgconf and this could even be done from /etc/abuild.conf.
-rw-r--r--testing/pkgconf/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/pkgconf/APKBUILD b/testing/pkgconf/APKBUILD
index 5bf96cfdb..ecdb9080e 100644
--- a/testing/pkgconf/APKBUILD
+++ b/testing/pkgconf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=pkgconf
pkgver=0.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="development framework configuration tools"
url="http://www.atheme.org/"
arch="all"
@@ -40,7 +40,9 @@ package() {
cd "$_builddir"
mkdir -p "$pkgdir"/usr/bin
make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
+ # we remove the pkg-config symlink since it breaks the build boxes
+ rm -f "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/bin/pkg-config
}
md5sums="87fe4e0128fbf0b9f9a393df37895052 pkgconf-0.1.1.tar.bz2"