summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-25 18:59:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-25 18:59:25 +0000
commit5eeffb09aa63ddd71a7266b07924107d5648f5ff (patch)
tree8aa6f40b032721adfe01377bd09169629914a755
parentf1e1192ed7e8859804f2f6d9398010adbd01bb13 (diff)
downloadaports-5eeffb09aa63ddd71a7266b07924107d5648f5ff.tar.bz2
aports-5eeffb09aa63ddd71a7266b07924107d5648f5ff.tar.xz
testing/shotwell: new aport
A digital photo organizer designed for the GNOME desktop environment http://yorba.org/shotwell/
-rw-r--r--testing/shotwell/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/shotwell/APKBUILD b/testing/shotwell/APKBUILD
new file mode 100644
index 000000000..17d556a41
--- /dev/null
+++ b/testing/shotwell/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=shotwell
+pkgver=0.8.1
+pkgrel=0
+pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
+url="http://yorba.org/shotwell/"
+arch="all"
+license="LGPL2.1"
+depends=""
+makedepends="intltool vala libgee-dev libunique-dev webkit-dev libexif-dev
+ librsvg-dev sqlite-dev udev-dev dbus-glib-dev libgphoto2-dev
+ libgexiv2-dev libraw-dev librsvg-dev gconf-dev json-glib-dev"
+install=
+source="http://yorba.org/download/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build ()
+{
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-schemas-install \
+ --disable-desktop-update \
+ --disable-icon-update
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="378168735006dfe0733431dd47f870c4 shotwell-0.8.1.tar.bz2"