summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-11-16 03:39:08 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-11-16 03:41:30 -0600
commit762e510f082f422e3219c9ec270bcf5b48395adf (patch)
tree78507912f8136fd43d2ef24c48d447699b1b5bd4
parent968ba98ecd762d28318716445141e5c1863deefb (diff)
downloadaports-762e510f082f422e3219c9ec270bcf5b48395adf.tar.bz2
aports-762e510f082f422e3219c9ec270bcf5b48395adf.tar.xz
main/linux-grsec: SMP-related bugfixes (see extended commit message)
[x86] - enable CONFIG_X86_BIGSMP - set CONFIG_NR_CPUS to 32 [x86_64] - set CONFIG_NR_CPUS to 32 With CONFIG_NR_CPUS > 8 on x86, the kernel may hang upon encountering more than 8 logical CPUs without CONFIG_X86_BIGSMP enabled. x86_64 does not have this problem, but as a side effect of the CONFIG_X86_BIGSMP change, needed to have CONFIG_NR_CPUS adjusted there as well. Discussions on various distribution lists: Alpine: http://lists.alpinelinux.org/alpine-devel/0496.html Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=480844 rPath: https://issues.rpath.com/browse/RPL-3022
-rw-r--r--main/linux-grsec/APKBUILD6
-rw-r--r--main/linux-grsec/kernelconfig.x866
-rw-r--r--main/linux-grsec/kernelconfig.x86_645
3 files changed, 8 insertions, 9 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index adbfc7bd5..cf9370625 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=3.0.9
_kernver=3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -144,5 +144,5 @@ md5sums="398e95866794def22b12dfbc15ce89c0 linux-3.0.tar.bz2
c41cf0ee9794f393423c6b2093072260 grsec-timblogiw-noconst.patch
ebb99ef6ad8cd2d9fd8f49d5c5849057 0001-ip_gre-dont-increase-dev-needed_headroom-on-a-live-d.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
-464e2356a1983e1ffe261904a1d76338 kernelconfig.x86
-d97d1808eebdfb97734dccfbcaea35f2 kernelconfig.x86_64"
+36330138ac7e1e776b3917a81ba51546 kernelconfig.x86
+f00f1c26ef7ddcdc4467bb883a71522b kernelconfig.x86_64"
diff --git a/main/linux-grsec/kernelconfig.x86 b/main/linux-grsec/kernelconfig.x86
index 463042587..e1a841c26 100644
--- a/main/linux-grsec/kernelconfig.x86
+++ b/main/linux-grsec/kernelconfig.x86
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Linux/i386 3.0.8 Kernel Configuration
+# Linux/i386 3.0.9 Kernel Configuration
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -270,7 +270,7 @@ CONFIG_HIGH_RES_TIMERS=y
CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
CONFIG_SMP=y
CONFIG_X86_MPPARSE=y
-# CONFIG_X86_BIGSMP is not set
+CONFIG_X86_BIGSMP=y
CONFIG_X86_EXTENDED_PLATFORM=y
# CONFIG_X86_MRST is not set
# CONFIG_X86_RDC321X is not set
@@ -339,7 +339,7 @@ CONFIG_HPET_EMULATE_RTC=y
CONFIG_DMI=y
# CONFIG_IOMMU_HELPER is not set
# CONFIG_IOMMU_API is not set
-CONFIG_NR_CPUS=8
+CONFIG_NR_CPUS=32
CONFIG_SCHED_SMT=y
CONFIG_SCHED_MC=y
CONFIG_IRQ_TIME_ACCOUNTING=y
diff --git a/main/linux-grsec/kernelconfig.x86_64 b/main/linux-grsec/kernelconfig.x86_64
index da9d1acec..bb9066f94 100644
--- a/main/linux-grsec/kernelconfig.x86_64
+++ b/main/linux-grsec/kernelconfig.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Linux/x86_64 3.0.3 Kernel Configuration
+# Linux/x86_64 3.0.9 Kernel Configuration
#
CONFIG_64BIT=y
# CONFIG_X86_32 is not set
@@ -321,7 +321,7 @@ CONFIG_GART_IOMMU=y
CONFIG_SWIOTLB=y
CONFIG_IOMMU_HELPER=y
# CONFIG_IOMMU_API is not set
-CONFIG_NR_CPUS=8
+CONFIG_NR_CPUS=32
CONFIG_SCHED_SMT=y
CONFIG_SCHED_MC=y
CONFIG_IRQ_TIME_ACCOUNTING=y
@@ -5013,7 +5013,6 @@ CONFIG_GRKERNSEC_PROC_IPADDR=y
#
# Executable Protections
#
-CONFIG_GRKERNSEC_EXECVE=y
# CONFIG_GRKERNSEC_DMESG is not set
CONFIG_GRKERNSEC_HARDEN_PTRACE=y
# CONFIG_GRKERNSEC_TPE is not set