summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2010-12-21 14:59:16 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2010-12-21 14:59:16 +0100
commita96c117627b6663198fafc2cffa16b6307fe3e50 (patch)
treebfe79be2beabb48a248b4c5f7e2d6146a46f6901
parent3ccb251e15e3a5692f737149080eecf48c25519a (diff)
downloadaports-a96c117627b6663198fafc2cffa16b6307fe3e50.tar.bz2
aports-a96c117627b6663198fafc2cffa16b6307fe3e50.tar.xz
testing/scstadmin: updated to version 2.0.0 svn r3161
small typo in initd
-rw-r--r--testing/iscsi-scst/APKBUILD24
-rw-r--r--testing/iscsi-scst/iscsi-scst.initd2
2 files changed, 14 insertions, 12 deletions
diff --git a/testing/iscsi-scst/APKBUILD b/testing/iscsi-scst/APKBUILD
index b92973159..f6f6c85b1 100644
--- a/testing/iscsi-scst/APKBUILD
+++ b/testing/iscsi-scst/APKBUILD
@@ -2,30 +2,31 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iscsi-scst
-pkgver=1.0.1.1
-pkgrel=2
+pkgver=2.0.0
+pkgrel=0
pkgdesc="ISCSI target for SCST - userspace tools"
url="http://iscsi-scst.sourceforge.net/"
-arch="x86 x86_64"
+arch="x86_64"
license="GPL-2"
depends=
install=
-makedepends="openssl-dev"
+makedepends="openssl-dev bash"
subpackages=
-source="http://downloads.sourceforge.net/scst/$pkgname-$pkgver.tar.gz
+_svn="3161"
+source="http://alpine.nethq.org/distfiles/$pkgname-$pkgver-svn-$_svn.tar.gz
+ http://alpine.nethq.org/distfiles/scst-$pkgver-svn-$_svn.tar.gz
iscsi-scst.initd
"
-_builddir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname
prepare() {
cd "$_builddir"
- # we need the headre file. fix dependency in makefile
- sed -i -e 's/^\(progs:.*\)/\1 include\/iscsi_scst_itf_ver.h/' Makefile
+ cp Makefile_user_space_only Makefile
}
build() {
cd "$_builddir"
- make progs
+ make all SCST_INC_DIR="$srcdir"/scst/include || return 1
}
package() {
@@ -36,5 +37,6 @@ package() {
install -D -m 755 "$srcdir"/iscsi-scst.initd "$pkgdir"/etc/init.d/iscsi-scst
}
-md5sums="56109c01e3d4421a36d6f47efa1fb0d5 iscsi-scst-1.0.1.1.tar.gz
-3132fae1ec2f9bcc72476d9e9f36d326 iscsi-scst.initd"
+md5sums="0980e7f0cc57d3a09cc57ba4b127ef12 iscsi-scst-2.0.0-svn-3161.tar.gz
+73c1ec37231918e5183e78f1ec8f2302 scst-2.0.0-svn-3161.tar.gz
+05efba84051393bf22ff1f2c718afbe9 iscsi-scst.initd"
diff --git a/testing/iscsi-scst/iscsi-scst.initd b/testing/iscsi-scst/iscsi-scst.initd
index 4d4cd76b5..3563bafa7 100644
--- a/testing/iscsi-scst/iscsi-scst.initd
+++ b/testing/iscsi-scst/iscsi-scst.initd
@@ -5,7 +5,7 @@
depend() {
need net
- afer firewall
+ after firewall
}
start() {