summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-11 12:34:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-11 12:34:26 +0000
commitde3639fdd85961a2c0fb73c4f0c0962eaa79c7fe (patch)
tree7b0be55636a3a3731f36c391572e386aacea69a4
parentc67e9240be4f9c03c0d33e37d293427b33cb1045 (diff)
downloadaports-de3639fdd85961a2c0fb73c4f0c0962eaa79c7fe.tar.bz2
aports-de3639fdd85961a2c0fb73c4f0c0962eaa79c7fe.tar.xz
testing/urwid: generate docs
-rw-r--r--testing/urwid/APKBUILD31
-rw-r--r--testing/urwid/tutorial_examples.tar.gzbin1526 -> 0 bytes
2 files changed, 10 insertions, 21 deletions
diff --git a/testing/urwid/APKBUILD b/testing/urwid/APKBUILD
index 7bcdcf27e..310c0b8f6 100644
--- a/testing/urwid/APKBUILD
+++ b/testing/urwid/APKBUILD
@@ -7,11 +7,10 @@ pkgdesc="Urwid is a console user interface library for Python"
url="http://excess.org/urwid/"
license="LGPL"
depends="python"
-makedepends="python-dev"
+makedepends="python-dev templayer"
install=
subpackages="$pkgname-doc"
source="http://excess.org/$pkgname/$pkgname-$pkgver.tar.gz
- tutorial_examples.tar.gz
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -22,31 +21,21 @@ prepare() {
}
build() {
+ cd "$_builddir"
+ python setup.py build
return 0
}
package() {
cd "$_builddir"
python setup.py install --root "$pkgdir"
-}
-
-doc() {
- mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
- cd "$_builddir"
-
- # generate tutorial examples, and tar it up
- # requires templayer to generate (how should subpackage deps be handled?)
- # for now, just including the generated tutorial_examples.tar.gz
- #python docgen_tutorial.py -s
- #mkdir tutorial_examples
- #mv example*.py tutorial_examples/
- #tar -czf tutorial_examples.tar.gz tutorial_examples/
- # copy documentation and example tarball
- install -Dm644 reference.html "$subpkgdir"/usr/share/doc/$pkgname/reference.html
- install -Dm644 tutorial.html "$subpkgdir"/usr/share/doc/$pkgname/tutorial.html
- install -Dm644 "$startdir"/tutorial_examples.tar.gz "$subpkgdir"/usr/share/doc/$pkgname/tutorial_examples.tar.gz
+ # generate tutorial examples, and copy documentation
+ python docgen_tutorial.py -s
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/tutorial_examples
+ cp -a example*.py "$pkgdir"/usr/share/doc/$pkgname/tutorial_examples/
+ install -Dm644 reference.html "$pkgdir"/usr/share/doc/$pkgname/reference.html
+ install -Dm644 tutorial.html "$pkgdir"/usr/share/doc/$pkgname/tutorial.html
}
-md5sums="4722cdf898f711dcae1121aa80920152 urwid-0.9.9.1.tar.gz
-6bd01421e332cd40b53d81911d02bc5b tutorial_examples.tar.gz"
+md5sums="4722cdf898f711dcae1121aa80920152 urwid-0.9.9.1.tar.gz"
diff --git a/testing/urwid/tutorial_examples.tar.gz b/testing/urwid/tutorial_examples.tar.gz
deleted file mode 100644
index aa61029a0..000000000
--- a/testing/urwid/tutorial_examples.tar.gz
+++ /dev/null
Binary files differ