summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-30 13:53:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-30 14:00:05 +0000
commitfbea6d88c1a709482a4f7af6de187c7a7d9ae840 (patch)
tree0c7f8fb9444d95f6820bcd3a4c0fede773e628d0
parent51f837bc40e2e7ce3ed4664e35794a3536f6d927 (diff)
downloadaports-fbea6d88c1a709482a4f7af6de187c7a7d9ae840.tar.bz2
aports-fbea6d88c1a709482a4f7af6de187c7a7d9ae840.tar.xz
main/libc0.9.32: don't define _POSIX_SPAWN
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/no-posix-spawn.patch24
2 files changed, 27 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 328368895..bb3643117 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
pkgname=libc$_abiver
_gitver=1006300816
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=1
+pkgrel=2
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -21,6 +21,7 @@ source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
uclibc-lutimes.patch
uclibc-resolv-tls.patch
uclibc-gcc-workaround.patch
+ no-posix-spawn.patch
uclibcconfig.x86
uclibcconfig.i486
"
@@ -103,5 +104,6 @@ md5sums="b7af86c013378888fbd345c47ad21c3a libc0.9.32-0.9.32_alpha0_git100630081
4d0b8170e6580b47bf5775e65a6f081e uclibc-lutimes.patch
d08831b452acdeaa3037525ee617edab uclibc-resolv-tls.patch
a88b7f394c86dc7aa606c9e338e35515 uclibc-gcc-workaround.patch
+cb3bfda1619a04218282cd02e3cdb4da no-posix-spawn.patch
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.x86
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.i486"
diff --git a/main/libc0.9.32/no-posix-spawn.patch b/main/libc0.9.32/no-posix-spawn.patch
new file mode 100644
index 000000000..c87e56491
--- /dev/null
+++ b/main/libc0.9.32/no-posix-spawn.patch
@@ -0,0 +1,24 @@
+commit 177538eb191c297ac146c843ff68d80ecfe9a87b
+Author: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri Jul 30 07:51:45 2010 +0000
+
+ nptl: do not define _POSIX_SPAWN since its not implemented
+
+ Building things like vlc checks if _POSIX_SPAWN is defined. Since
+ posix_spawn is not implemented we dont define it.
+
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h b/libpthread/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+index 2550355..6fbdbb7 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/bits/posix_opt.h
+@@ -143,8 +143,10 @@
+ /* We support spinlocks. */
+ #define _POSIX_SPIN_LOCKS 200809L
+
++#if 0
+ /* The `spawn' function family is supported. */
+ #define _POSIX_SPAWN 200809L
++#endif
+
+ /* We have POSIX timers. */
+ #define _POSIX_TIMERS 200809L