summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-10-21 06:58:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-10-21 06:58:18 +0000
commit1a3e4a61126ee2e8f1470d6997e861c56aaee3ee (patch)
treef9fcebe590765c79068aaf9fde7b9ce58a7868c4 /core
parentd85401acbe2670f4c019057d367b849876afdc61 (diff)
downloadaports-1a3e4a61126ee2e8f1470d6997e861c56aaee3ee.tar.bz2
aports-1a3e4a61126ee2e8f1470d6997e861c56aaee3ee.tar.xz
added autoconf
Diffstat (limited to 'core')
-rw-r--r--core/autoconf/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/core/autoconf/APKBUILD b/core/autoconf/APKBUILD
new file mode 100644
index 000000000..7326d8eb0
--- /dev/null
+++ b/core/autoconf/APKBUILD
@@ -0,0 +1,25 @@
+
+pkgname=autoconf
+pkgver=2.63
+pkgrel=1
+pkgdesc="A GNU tool for automatically configuring source code"
+arch=i486
+license="GPL2 GPL3"
+url="http://www.gnu.org/software/autoconf"
+depends="m4 perl"
+makedepends="binutils gcc make linux-headers perl uclibc-dev"
+install=autoconf.install
+source="ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+subpackages="doc"
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ rm -f ${pkgdir}/usr/share/info/dir
+ # conflict with bintuils
+ rm -f ${pkgdir}/usr/share/info/standards.info
+}
+
+md5='43d76649fb86cd21d64f68c48d5abdcf autoconf-2.63.tar.gz'