summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-10-21 07:29:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-10-21 07:29:07 +0000
commita2333607a45cf9e4a92b3ccfcfe8258f9b880b1c (patch)
tree027abb2dcae4a790dcd32cbf8d661f16ac3cd400 /core
parente44f13d6991b05de1c54af5b5e06d0cd62c5c34c (diff)
downloadaports-a2333607a45cf9e4a92b3ccfcfe8258f9b880b1c.tar.bz2
aports-a2333607a45cf9e4a92b3ccfcfe8258f9b880b1c.tar.xz
new aport: tdb
Diffstat (limited to 'core')
-rw-r--r--core/tdb/APKBUILD23
-rw-r--r--core/tdb/tdb-1.0.6-gcc3.patch41
-rw-r--r--core/tdb/tdb-1.0.6-no-gdbm.patch16
3 files changed, 80 insertions, 0 deletions
diff --git a/core/tdb/APKBUILD b/core/tdb/APKBUILD
new file mode 100644
index 000000000..962879978
--- /dev/null
+++ b/core/tdb/APKBUILD
@@ -0,0 +1,23 @@
+pkgdesc="A Trivial Database"
+pkgname=tdb
+pkgver=1.0.6
+pkgrel=1
+url="http://sourceforge.net/projects/tdb"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname-1.0.6-gcc3.patch
+ $pkgname-1.0.6-no-gdbm.patch"
+license="GPL-2"
+subpackages="dev doc"
+makedepends="binutils gcc linux-headers make uclibc-dev"
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 -i $srcdir/$pkgname-1.0.6-gcc3.patch || return 1
+ patch -p0 -i $srcdir/$pkgname-1.0.6-no-gdbm.patch || return 1
+ ./configure --prefix=/usr
+ make || return 1
+ make install DESTDIR=$pkgdir
+}
+md5="6b643fdeb48304010dcd5f675e458b58 tdb-1.0.6.tar.gz
+3dbbde1145303ad43730f2bc1bb3b82b tdb-1.0.6-gcc3.patch
+8a4247a9e3c5af757cfa1d5c20733642 tdb-1.0.6-no-gdbm.patch"
diff --git a/core/tdb/tdb-1.0.6-gcc3.patch b/core/tdb/tdb-1.0.6-gcc3.patch
new file mode 100644
index 000000000..a17afbac9
--- /dev/null
+++ b/core/tdb/tdb-1.0.6-gcc3.patch
@@ -0,0 +1,41 @@
+--- tdb-1.0.6/tdbtool.c.old 2001-12-10 22:45:47.000000000 -0500
++++ tdb-1.0.6/tdbtool.c 2003-10-02 22:41:51.000000000 -0400
+@@ -169,22 +169,22 @@
+
+ static void help(void)
+ {
+- printf("
+-tdbtool:
+- create dbname : create a database
+- open dbname : open an existing database
+- erase : erase the database
+- dump dumpname : dump the database as strings
+- insert key data : insert a record
+- store key data : store a record (replace)
+- show key : show a record by key
+- delete key : delete a record by key
+- list : print the database hash table and freelist
+- free : print the database freelist
+- 1 | first : print the first record
+- n | next : print the next record
+- q | quit : terminate
+- \\n : repeat 'next' command
++ printf("\n\
++tdbtool:\n\
++ create dbname : create a database\n\
++ open dbname : open an existing database\n\
++ erase : erase the database\n\
++ dump dumpname : dump the database as strings\n\
++ insert key data : insert a record\n\
++ store key data : store a record (replace)\n\
++ show key : show a record by key\n\
++ delete key : delete a record by key\n\
++ list : print the database hash table and freelist\n\
++ free : print the database freelist\n\
++ 1 | first : print the first record\n\
++ n | next : print the next record\n\
++ q | quit : terminate\n\
++ \\n : repeat 'next' command\n\
+ ");
+ }
+
diff --git a/core/tdb/tdb-1.0.6-no-gdbm.patch b/core/tdb/tdb-1.0.6-no-gdbm.patch
new file mode 100644
index 000000000..0f4703076
--- /dev/null
+++ b/core/tdb/tdb-1.0.6-no-gdbm.patch
@@ -0,0 +1,16 @@
+gdbm is only used in tdbspeed and tdbtest which never get
+installed, so lets go ahead and force disable gdbm "support"
+
+http://bugs.gentoo.org/113824
+
+--- Makefile.in
++++ Makefile.in
+@@ -80,7 +80,7 @@
+ @BUILD_TDBTORTURE_TRUE@TDBTORTURE = tdbtorture
+ @BUILD_TDBTORTURE_FALSE@TDBTORTURE =
+
+-noinst_PROGRAMS = tdbspeed tdbiterate $(TDBTEST) $(TDBTORTURE)
++noinst_PROGRAMS = tdbiterate $(TDBTORTURE)
+ bin_PROGRAMS = tdbtool tdbdump
+
+ lib_LTLIBRARIES = libtdb.la