summaryrefslogtreecommitdiffstats
path: root/extra/fetchmail
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-27 07:48:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-27 07:48:38 +0000
commita605bcc86481c442d8d8554d89a4d380611fe572 (patch)
tree8bcb8db5856c7db8ba77c2fae47a548e2d6e87f3 /extra/fetchmail
parent3eb1befcd88fe9c7c39a43e77ab108726f340f46 (diff)
downloadaports-a605bcc86481c442d8d8554d89a4d380611fe572.tar.bz2
aports-a605bcc86481c442d8d8554d89a4d380611fe572.tar.xz
extra/fetchmail: split out fetchmailconf to a separate package
Diffstat (limited to 'extra/fetchmail')
-rw-r--r--extra/fetchmail/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/extra/fetchmail/APKBUILD b/extra/fetchmail/APKBUILD
index d209ead51..e04e23c34 100644
--- a/extra/fetchmail/APKBUILD
+++ b/extra/fetchmail/APKBUILD
@@ -1,5 +1,5 @@
-# Contributor:
-# Maintainer:
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fetchmail
pkgver=6.3.9
pkgrel=0
@@ -7,9 +7,9 @@ pkgdesc="A remote-mail retrieval and forwarding utility"
url="http://fetchmail.berlios.de/"
license="GPL"
depends="openssl uclibc"
-makedepends=""
+makedepends="openssl-dev"
install=
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc fetchmailconf"
source="http://download.berlios.de/fetchmail/$pkgname-$pkgver.tar.bz2
fetchmail.initrd"
build() {
@@ -19,11 +19,21 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --with-ssl \
--disable-nls
make || return 1
make DESTDIR="$pkgdir" install
install -Dm755 $srcdir/fetchmail.initrd "$pkgdir"/etc/init.d/fetchmail
}
+fetchmailconf() {
+ depends="python"
+ pkgdesc="A GUI for generating fetchmail configuration files"
+ mkdir -p "$subpkgdir"/usr/bin
+ cd "$pkgdir"
+ mv usr/bin/fetchmailconf "$subpkgdir"/usr/bin/
+ mv usr/lib "$subpkgdir"/usr/
+}
+
md5sums="72c20ad2b9629f1a109668b05a84d823 fetchmail-6.3.9.tar.bz2
b6b95767279d77c98acdc3aa4d00ec89 fetchmail.initrd"