summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2009-03-25 21:46:06 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2009-03-25 21:46:06 +0000
commitbbd7886cd79ad2060c9199c768991035228905f7 (patch)
treefdacf17a220d58d6ef0bf0a4d7dd0346161f5a78 /extra
parent044bf35ebe0ece74d5a386050c69f77b82a9f0ff (diff)
downloadaports-bbd7886cd79ad2060c9199c768991035228905f7.tar.bz2
aports-bbd7886cd79ad2060c9199c768991035228905f7.tar.xz
extra/transmission: updated install file to new style.
fixes #16
Diffstat (limited to 'extra')
-rw-r--r--extra/transmission/APKBUILD7
-rw-r--r--extra/transmission/transmission-1.34-configure-no-nls.patch47
-rw-r--r--extra/transmission/transmission.install9
-rw-r--r--extra/transmission/transmission.pre-install5
4 files changed, 8 insertions, 60 deletions
diff --git a/extra/transmission/APKBUILD b/extra/transmission/APKBUILD
index a7796fc76..b3886e3d3 100644
--- a/extra/transmission/APKBUILD
+++ b/extra/transmission/APKBUILD
@@ -4,15 +4,14 @@ pkgver=1.51
pkgel=0
pkgdesc="Fast, easy, and fee BitToent client (CLI tools daemon and webinterface)"
url="http://www.tansmissionbt.com"
-install=transmission.install
+install="$pkgname.pre-install"
license="MIT"
depends="curl"
makedepends="openssl-dev pkgconfig curl-dev"
source="http://download.m0k.org/transmission/files/transmission-$pkgver.tar.bz2
transmission-daemon.initd
transmission-daemon.confd
- transmission.install
- "
+ $pkgname.pre-install"
subpackages="$pkgname-doc"
build() {
@@ -30,4 +29,4 @@ build() {
md5sums="b93439fbd0040ad6eb448f70a48355f5 transmission-1.51.tar.bz2
b3b921242bdc3b33a8ac05fc30653b6c transmission-daemon.initd
89478a70fcd93463e1dd8d751da994da transmission-daemon.confd
-4e338c4f7c902e132707b9e87b9bf1b5 transmission.install"
+f1c8d94e1f7ff77c23a7e92d3860754d transmission.pre-install"
diff --git a/extra/transmission/transmission-1.34-configure-no-nls.patch b/extra/transmission/transmission-1.34-configure-no-nls.patch
deleted file mode 100644
index 551d62461..000000000
--- a/extra/transmission/transmission-1.34-configure-no-nls.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- transmission-1.34.orig/configure Fri Nov 28 15:54:27 2008
-+++ transmission-1.34/configure Fri Nov 28 15:57:05 2008
-@@ -23735,22 +23735,7 @@
- ;;
- esac
-
--if test -n "0.23"; then
-- { echo "$as_me:$LINENO: checking for intltool >= 0.23" >&5
--echo $ECHO_N "checking for intltool >= 0.23... $ECHO_C" >&6; }
-
-- INTLTOOL_REQUIRED_VERSION_AS_INT=`echo 0.23 | awk -F. '{ print $ 1 * 1000 + $ 2 * 100 + $ 3; }'`
-- INTLTOOL_APPLIED_VERSION=`awk -F\" '/\\$VERSION / { print $ 2; }' ${ac_aux_dir}/intltool-update.in`
-- INTLTOOL_APPLIED_VERSION_AS_INT=`awk -F\" '/\\$VERSION / { split($ 2, VERSION, "."); print VERSION[1] * 1000 + VERSION[2] * 100 + VERSION[3];}' ${ac_aux_dir}/intltool-update.in`
--
-- { echo "$as_me:$LINENO: result: $INTLTOOL_APPLIED_VERSION found" >&5
--echo "${ECHO_T}$INTLTOOL_APPLIED_VERSION found" >&6; }
-- test "$INTLTOOL_APPLIED_VERSION_AS_INT" -ge "$INTLTOOL_REQUIRED_VERSION_AS_INT" ||
-- { { echo "$as_me:$LINENO: error: Your intltool is too old. You need intltool 0.23 or later." >&5
--echo "$as_me: error: Your intltool is too old. You need intltool 0.23 or later." >&2;}
-- { (exit 1); exit 1; }; }
--fi
--
- INTLTOOL_DESKTOP_RULE='%.desktop: %.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
- INTLTOOL_DIRECTORY_RULE='%.directory: %.directory.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
- INTLTOOL_KEYS_RULE='%.keys: %.keys.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -k -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
-@@ -23909,21 +23894,6 @@
- else
- { echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6; }
--fi
--
--
--if test -z "$XGETTEXT" -o -z "$MSGMERGE" -o -z "$MSGFMT"; then
-- { { echo "$as_me:$LINENO: error: GNU gettext tools not found; required for intltool" >&5
--echo "$as_me: error: GNU gettext tools not found; required for intltool" >&2;}
-- { (exit 1); exit 1; }; }
--fi
--xgversion="`$XGETTEXT --version|grep '(GNU ' 2> /dev/null`"
--mmversion="`$MSGMERGE --version|grep '(GNU ' 2> /dev/null`"
--mfversion="`$MSGFMT --version|grep '(GNU ' 2> /dev/null`"
--if test -z "$xgversion" -o -z "$mmversion" -o -z "$mfversion"; then
-- { { echo "$as_me:$LINENO: error: GNU gettext tools not found; required for intltool" >&5
--echo "$as_me: error: GNU gettext tools not found; required for intltool" >&2;}
-- { (exit 1); exit 1; }; }
- fi
-
- # Use the tools built into the package, not the ones that are installed.
diff --git a/extra/transmission/transmission.install b/extra/transmission/transmission.install
deleted file mode 100644
index 870b5e29e..000000000
--- a/extra/transmission/transmission.install
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-case $1 in
- pre_install)
- adduser -h /var/lib/transmission -s /bin/false -D transmission 2>/dev/null
- ;;
-esac
-
-exit 0
diff --git a/extra/transmission/transmission.pre-install b/extra/transmission/transmission.pre-install
new file mode 100644
index 000000000..44a14760f
--- /dev/null
+++ b/extra/transmission/transmission.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+adduser -h /var/lib/transmission -s /bin/false -D transmission 2>/dev/null
+
+exit 0