summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2009-03-26 16:19:44 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2009-03-26 16:19:44 +0000
commitc5ba09ce15edd772b2da9aba4885ed0aa98b6140 (patch)
treedc10d0735b825dcd3ec8b35fc9524102e06dcccb /extra
parenta0e1257e5a4f840c5b706aac57fef63c8030b8de (diff)
parentf71e31f6311c85bbcd3232d035f9414f571af9d5 (diff)
downloadaports-c5ba09ce15edd772b2da9aba4885ed0aa98b6140.tar.bz2
aports-c5ba09ce15edd772b2da9aba4885ed0aa98b6140.tar.xz
Merge commit 'ncopa/master'
Diffstat (limited to 'extra')
-rw-r--r--extra/aumix/aumix-2.8-mute.patch16
-rw-r--r--extra/aumix/aumix-2.8-nohome.patch12
-rw-r--r--extra/aumix/aumix-2.8-save_load.patch45
-rw-r--r--extra/aumix/aumix.initd42
-rw-r--r--extra/cgit/APKBUILD9
-rw-r--r--extra/ksymoops/APKBUILD25
6 files changed, 145 insertions, 4 deletions
diff --git a/extra/aumix/aumix-2.8-mute.patch b/extra/aumix/aumix-2.8-mute.patch
new file mode 100644
index 000000000..8a32fd5b9
--- /dev/null
+++ b/extra/aumix/aumix-2.8-mute.patch
@@ -0,0 +1,16 @@
+Fix mute script: save volume and then set it to 0 instead of saving it directly
+to 0. Bug #122087.
+Index: aumix-2.8/src/mute
+===================================================================
+--- aumix-2.8.orig/src/mute
++++ aumix-2.8/src/mute
+@@ -8,7 +8,8 @@
+ volumes=$(aumix -vq |tr -d ,)
+ if [ $(echo $volumes | awk '{print $2}') -ne 0 -o \
+ $(echo $volumes | awk '{print $3}') -ne 0 ]; then
+- aumix -S -v 0
++ aumix -S
++ aumix -v 0
+ else
+ aumix -L > /dev/null
+ fi
diff --git a/extra/aumix/aumix-2.8-nohome.patch b/extra/aumix/aumix-2.8-nohome.patch
new file mode 100644
index 000000000..bf20f0372
--- /dev/null
+++ b/extra/aumix/aumix-2.8-nohome.patch
@@ -0,0 +1,12 @@
+diff -Naur aumix-2.8.orig/src/common.c aumix-2.8/src/common.c
+--- aumix-2.8.orig/src/common.c 2002-10-29 13:27:51.000000000 -0800
++++ aumix-2.8/src/common.c 2004-07-22 01:28:07.684999900 -0700
+@@ -591,7 +591,7 @@
+ char filename[PATH_MAX];
+ if (save_filename == NULL) {
+ home = getenv("HOME");
+- if ((strlen(home) + strlen(AUMIXRC) + 2) < PATH_MAX) {
++ if (home && (strlen(home) + strlen(AUMIXRC) + 2) < PATH_MAX) {
+ sprintf(filename, "%s/.%s", home, AUMIXRC);
+ setfile = CheckAndOpen(filename, mode);
+ }
diff --git a/extra/aumix/aumix-2.8-save_load.patch b/extra/aumix/aumix-2.8-save_load.patch
new file mode 100644
index 000000000..498716b51
--- /dev/null
+++ b/extra/aumix/aumix-2.8-save_load.patch
@@ -0,0 +1,45 @@
+--- a/src/common.c 2002-11-28 14:22:00.000000000 +0100
++++ b/src/common.c 2002-11-28 14:23:11.000000000 +0100
+@@ -116,6 +116,7 @@
+ int main(int argc, char *argv[])
+ {
+ int optn, ii;
++ int save = 0, load = 0;
+ #ifdef HAVE_CURSES
+ int setcolors = FALSE;
+ #endif /* HAVE_CURSES */
+@@ -171,14 +172,10 @@
+ break;
+ #endif /* HAVE_CURSES */
+ case 'S': /* Save to file. */
+- if (mixer_fd == -1)
+- ErrorExitWarn(InitializeMixer(device_filename), 'e');
+- ErrorExitWarn(SaveSettings(), 'e');
++ save = 1;
+ break;
+ case 'L': /* Load from file. */
+- if (mixer_fd == -1)
+- ErrorExitWarn(InitializeMixer(device_filename), 'e');
+- ErrorExitWarn(LoadSettings(), 'e');
++ load = 1;
+ break;
+ #if defined (HAVE_CURSES) || defined (HAVE_GTK) || defined (HAVE_GTK1)
+ case 'I': /* User asked for interactive mode. */
+@@ -194,6 +191,17 @@
+ }
+ }
+ }
++ if (save | load) {
++ if (mixer_fd == -1)
++ ErrorExitWarn(InitializeMixer(device_filename), 'e');
++ if (save)
++ ErrorExitWarn(SaveSettings(), 'e');
++ else
++ ErrorExitWarn(LoadSettings(), 'e');
++ close(mixer_fd);
++ exit(EXIT_SUCCESS);
++ }
++
+ #if defined (HAVE_CURSES) || defined (HAVE_GTK) || defined (HAVE_GTK1)
+ /* Be interactive if no options were given. */
+ if (!interactive && argc <= 1)
diff --git a/extra/aumix/aumix.initd b/extra/aumix/aumix.initd
new file mode 100644
index 000000000..2c1741b3b
--- /dev/null
+++ b/extra/aumix/aumix.initd
@@ -0,0 +1,42 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/files/aumix.rc6,v 1.12 2007/03/25 13:05:51 drac Exp $
+
+depend() {
+ use modules hotplug coldplug alsasound
+}
+
+checkconfig() {
+ if ! grep -q -E 'sound|OSS|sparcaudio' /proc/devices && [ ! -d /proc/asound ] ; then
+ eerror "Sound support has not been compiled into the kernel,"
+ eerror "or is disabled. Please check that the correct modules"
+ eerror "is loaded."
+ return 1
+ fi
+ # /dev/mixer can be a symlink
+ if [ ! -e /dev/mixer ] ; then
+ eerror "/dev/mixer does not exist, please create it, or load the"
+ eerror "correct modules to enable your card's mixer"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ if [ -f /etc/aumixrc ] ; then
+ ebegin "Loading Mixer settings"
+ /usr/bin/aumix -f /etc/aumixrc -L >/dev/null 2>&1
+ else
+ ebegin "Setting Mixer settings"
+ /usr/bin/aumix -v75 -c75 -w75 >/dev/null 2>&1
+ fi
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+ ebegin "Saving Mixer settings"
+ /usr/bin/aumix -f /etc/aumixrc -S >/dev/null 2>&1
+ eend $?
+}
diff --git a/extra/cgit/APKBUILD b/extra/cgit/APKBUILD
index 756765284..eec91bef8 100644
--- a/extra/cgit/APKBUILD
+++ b/extra/cgit/APKBUILD
@@ -1,6 +1,7 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cgit
-pkgver=0.8.2
-_gitver=1.6.1.1
+pkgver=0.8.2.1
+_gitver=1.6.2.1
pkgdesc="a fast webinterface for git"
url="http://hjemli.net/git/cgit"
license=GPL-2
@@ -23,5 +24,5 @@ build() {
ln -s cgit.cgi "$pkgdir"/usr/share/webapps/cgit/cgit
}
-md5sums="6887c96f51c7f3bb2b9c8f6c6b0378f5 cgit-0.8.2.tar.gz
-d2b6925cb03e1e33911fdf9392946747 git-1.6.1.1.tar.bz2"
+md5sums="12f5468a948be40c275445253e73d309 cgit-0.8.2.1.tar.gz
+e96481361887f63227fdaa5ccdbb03b7 git-1.6.2.1.tar.bz2"
diff --git a/extra/ksymoops/APKBUILD b/extra/ksymoops/APKBUILD
new file mode 100644
index 000000000..d8cc04fdf
--- /dev/null
+++ b/extra/ksymoops/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ksymoops
+pkgver=2.4.11
+pkgrel=0
+pkgdesc="A Linux kernel Oops file troubleshooting tool"
+url="ftp://ftp.kernel.org/pub/linux/utils/kernel/ksymoops/v2.4"
+license="GPL-2"
+depends="uclibc"
+makedepends="!gettext !libiconv"
+source="ftp://ftp.kernel.org/pub/linux/utils/kernel/$pkgname/v2.4/$pkgname-$pkgver.tar.bz2
+ $pkgname-2.4.11-build.patch
+ "
+subpackages="$pkgname-doc"
+
+build ()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < ../$pkgname-2.4.11-build.patch || return 1
+ make || return 1
+ make install \
+ INSTALL_PREFIX="$pkgdir"/usr \
+ INSTALL_MANDIR="$pkgdir"/usr/share/man
+}
+md5sums="4a8249e182a5dbc75e566d162e9f3314 ksymoops-2.4.11.tar.bz2
+bad82d31c7d15431fc022be237791d59 ksymoops-2.4.11-build.patch"