summaryrefslogtreecommitdiffstats
path: root/main/abiword
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-05-14 17:25:51 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-05-14 17:25:51 -0500
commit3a6f2abfd79de7b8e1e3acac4d5e25c432b7416f (patch)
tree21130d5d07451ca49321e2db3cb4e1c885696459 /main/abiword
parent438cb611c67fe869a70e45cbb38a28fbd8aea7ed (diff)
downloadaports-3a6f2abfd79de7b8e1e3acac4d5e25c432b7416f.tar.bz2
aports-3a6f2abfd79de7b8e1e3acac4d5e25c432b7416f.tar.xz
main/abiword: fix compile with libpng 1.5
Diffstat (limited to 'main/abiword')
-rw-r--r--main/abiword/APKBUILD6
-rw-r--r--main/abiword/abiword-png15.patch48
2 files changed, 51 insertions, 3 deletions
diff --git a/main/abiword/APKBUILD b/main/abiword/APKBUILD
index 1a9271c67..232a62ab1 100644
--- a/main/abiword/APKBUILD
+++ b/main/abiword/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=2.8.6
-pkgrel=3
+pkgrel=4
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
-arch=""
+arch="all"
license="GPL"
makedepends="pkgconfig libglade-dev libgsf-dev enchant-dev fribidi-dev wv-dev
popt-dev jpeg-dev librsvg-dev bzip2-dev goffice-dev"
@@ -73,4 +73,4 @@ plugins() {
}
md5sums="f883b0a7f26229a9c66fd6a1a94381aa abiword-2.8.6.tar.gz
-08a7fd39dbec279e0eea33fc70692093 abiword-png15.patch"
+1d0bb11ed10b431ab312173de81d12c4 abiword-png15.patch"
diff --git a/main/abiword/abiword-png15.patch b/main/abiword/abiword-png15.patch
index ead8bf348..b17bb85bf 100644
--- a/main/abiword/abiword-png15.patch
+++ b/main/abiword/abiword-png15.patch
@@ -31,3 +31,51 @@ diff -Naur abiword-vanilla//src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp abiwor
{
/* Free all of the memory associated with the png_ptr and info_ptr */
png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
+--- abiword-vanilla/plugins/garble/xp/abiword-garble-png.cpp
++++ abiword-2.8.6/plugins/garble/xp/abiword-garble-png.cpp
+@@ -79,7 +79,7 @@
+ png_set_strip_alpha( png_ptr );
+ png_set_interlace_handling( png_ptr );
+ png_set_bgr( png_ptr );
+- rowbytes = info_ptr->rowbytes;
++ rowbytes = png_get_rowbytes( png_ptr, info_ptr );
+ png_destroy_read_struct( &png_ptr, &info_ptr, NULL );
+ }
+
+--- abiword-vanilla/plugins/bmp/xp/ie_impGraphic_BMP.cpp
++++ abiword-2.8.6/plugins/bmp/xp/ie_impGraphic_BMP.cpp
+@@ -191,7 +191,6 @@
+
+ /* Clean Up Memory Used */
+
+- FREEP(m_pPNGInfo->palette);
+ DELETEP(pBB);
+ png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
+
+@@ -313,7 +312,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(m_pPNG->jmpbuf))
++ if (setjmp(png_jmpbuf(m_pPNG)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
+@@ -332,7 +331,7 @@
+ UT_Error IE_ImpGraphic_BMP::Convert_BMP_Pallet(UT_ByteBuf* pBB)
+ {
+ /* Reset error handling for libpng */
+- if (setjmp(m_pPNG->jmpbuf))
++ if (setjmp(png_jmpbuf(m_pPNG)))
+ {
+ png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
+ return UT_ERROR;
+@@ -372,7 +371,7 @@
+ UT_Error IE_ImpGraphic_BMP::Convert_BMP(UT_ByteBuf* pBB)
+ {
+ /* Reset error handling for libpng */
+- if (setjmp(m_pPNG->jmpbuf))
++ if (setjmp(png_jmpbuf(m_pPNG)))
+ {
+ png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
+ return UT_ERROR;