summaryrefslogtreecommitdiffstats
path: root/main/abiword
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-14 17:59:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-14 17:59:48 +0000
commitd15964ab95df39fe1a0633800cd5d886dfabf074 (patch)
tree5d81f9869ae6290dc953a1ab8e432adf81e46f65 /main/abiword
parent9ca82f726fc4b1f0a2391b06d5ac7656d66cefab (diff)
downloadaports-d15964ab95df39fe1a0633800cd5d886dfabf074.tar.bz2
aports-d15964ab95df39fe1a0633800cd5d886dfabf074.tar.xz
main/abiword: build plugins
Diffstat (limited to 'main/abiword')
-rw-r--r--main/abiword/APKBUILD45
1 files changed, 34 insertions, 11 deletions
diff --git a/main/abiword/APKBUILD b/main/abiword/APKBUILD
index 3ecdf6aa6..c134f1992 100644
--- a/main/abiword/APKBUILD
+++ b/main/abiword/APKBUILD
@@ -1,14 +1,31 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=2.8.4
-pkgrel=1
+pkgrel=2
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
license="GPL"
makedepends="pkgconfig libglade-dev libgsf-dev enchant-dev fribidi-dev wv-dev
popt-dev jpeg-dev librsvg-dev bzip2-dev goffice-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-plugin-goffice:goffice
- $pkgname-plugin-opendocument:opendocument"
+
+# openxml plugin
+makedepends="$makedepends boost-dev"
+
+# collab plugin
+makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
+
+
+subpackages="$pkgname-dev $pkgname-doc $pkgname-plugins"
+
+_plugins="applix babelfish bmp clarisworks collab docbook eml freetranslation
+ garble gdict gimp google hancom hrtext iscii kword loadbindings mht
+ mif mswrite openwriter openxml opml paint passepartout pdb pdf
+ presentation s5 sdw t602 urldict wikipedia wml xslfo"
+
+for _i in $_plugins; do
+ subpackages="$subpackages $pkgname-plugin-$_i:$_i"
+done
+
source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz"
build() {
@@ -16,30 +33,36 @@ build() {
./configure --prefix=/usr \
--enable-shared \
--disable-static \
- --enable-plugins="opendocument goffice" \
+ --enable-plugins \
|| return 1
make || return 1
}
+# ="opendocument goffice latex" \
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
-_plugin() {
+_do_plugin() {
local plugin="$1"
- pkgdesc="$2"
+ pkgdesc="Abiword $1 plugin"
local dir="usr/lib/abiword-${pkgver%.*}/plugins"
mkdir -p "$subpkgdir"/$dir
mv "$pkgdir"/$dir/$plugin.so "$subpkgdir"/$dir/
}
-goffice() {
- _plugin goffice "GOffice interaction plugin for AbiWord"
-}
+for _i in $_plugins; do
+ eval "$_i() { _do_plugin $_i; }"
+done
-opendocument() {
- _plugin opendocument "OpenDocument support plugin for AbiWord"
+plugins() {
+ pkgdesc="Abiword plugins, all of them"
+ depends=
+ for _i in $_plugins; do
+ depends="$depends $pkgname-plugin-$_i"
+ done
+ mkdir -p "$subpkgdir"
}
md5sums="f782ecb8e07d07ec179f7a143353cc29 abiword-2.8.4.tar.gz"