summaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-10 11:56:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-10 11:56:42 +0000
commit1cab737be3b8391dd2b845e3dfe75d6b99460117 (patch)
tree95d2df922b737701a61a0b044866ba9a807c63c5 /main/abuild
parent63cbdb27e349a4dce9d6c51fdcf86df802e9d6c6 (diff)
downloadaports-1cab737be3b8391dd2b845e3dfe75d6b99460117.tar.bz2
aports-1cab737be3b8391dd2b845e3dfe75d6b99460117.tar.xz
main/abuild: add support for option 'ldpath-recursive'
It is needed for building openjdk6
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/APKBUILD6
-rw-r--r--main/abuild/abuild-git-20120910.patch (renamed from main/abuild/abuild-git-20120908.patch)14
2 files changed, 12 insertions, 8 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 0aaaf26d7..76f168d20 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.12.1
-pkgrel=5
+pkgrel=6
url=http://git.alpinelinux.org/cgit/abuild/
depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1 uclibc-utils
abuildhelper curl"
@@ -13,7 +13,7 @@ pkggroups="abuild"
arch="all"
license=GPL-2
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
- abuild-git-20120908.patch"
+ abuild-git-20120910.patch"
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -48,4 +48,4 @@ cpan() {
}
md5sums="92348750a3354c3ec7b811716543b8e5 abuild-2.12.1.tar.bz2
-877d6a683752d9cca041b2b545901fd8 abuild-git-20120908.patch"
+20b3511f09b8e60e33fb162b0c5646db abuild-git-20120910.patch"
diff --git a/main/abuild/abuild-git-20120908.patch b/main/abuild/abuild-git-20120910.patch
index 847f76749..08d767b45 100644
--- a/main/abuild/abuild-git-20120908.patch
+++ b/main/abuild/abuild-git-20120910.patch
@@ -1,5 +1,5 @@
diff --git a/abuild.in b/abuild.in
-index 2780d2e..60cb91c 100755
+index 2780d2e..db9fdf9 100755
--- a/abuild.in
+++ b/abuild.in
@@ -404,6 +404,9 @@ default_unpack() {
@@ -64,7 +64,7 @@ index 2780d2e..60cb91c 100755
found=${j%/.provides-so}
found=${found##*/.control.}
break
-@@ -911,26 +911,106 @@ trace_apk_deps() {
+@@ -911,26 +911,110 @@ trace_apk_deps() {
fi
done
@@ -100,15 +100,19 @@ index 2780d2e..60cb91c 100755
+
+scan_shared_objects() {
+ local name="$1" controldir="$2" datadir="$3"
++ local opt=
+
+ # allow spaces in paths
+ IFS=:
+ set -- $(find_scanelf_paths "$controldir" "$datadir")
+ unset IFS
+
++ if options_has "ldpath-recursive"; then
++ opt="--recursive"
++ fi
+ msg "Scanning shared objects"
+ # lets tell all the .so files this package provides in .provides-so
-+ scanelf --nobanner --soname "$@" | while read etype soname file; do
++ scanelf --nobanner --soname $opt "$@" | while read etype soname file; do
+ # if soname field is missing, soname will be the filepath
+ sover=0
+ if [ -z "$file" ]; then
@@ -179,7 +183,7 @@ index 2780d2e..60cb91c 100755
(
cd "$datadir"
# data.tar.gz
-@@ -941,6 +1021,7 @@ create_apks() {
+@@ -941,6 +1025,7 @@ create_apks() {
fi
tar -c "$@" | abuild-tar --hash | gzip -9 >"$dir"/data.tar.gz
@@ -187,7 +191,7 @@ index 2780d2e..60cb91c 100755
# append the hash for data.tar.gz
local sha256=$(sha256sum "$dir"/data.tar.gz | cut -f1 -d' ')
echo "datahash = $sha256" >> "$dir"/.PKGINFO
-@@ -951,10 +1032,12 @@ create_apks() {
+@@ -951,10 +1036,12 @@ create_apks() {
| gzip -9 > control.tar.gz
abuild-sign -q control.tar.gz || exit 1