summaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-04 13:57:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-08-16 12:50:06 +0000
commit52dcc2d72d64266246f6d6253b8c9804d4d538c6 (patch)
treea3fcbeb968eeeb0ece88764c3c7b5e3d2625dca0 /main/abuild
parent0b4ebd18832b300a78a05aac12a5c949f34e48f6 (diff)
downloadaports-52dcc2d72d64266246f6d6253b8c9804d4d538c6.tar.bz2
aports-52dcc2d72d64266246f6d6253b8c9804d4d538c6.tar.xz
main/abuild: start add 'provides' info
ref #574
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-use-scanelf-soname-to-find-the-provides-so.patch32
-rw-r--r--main/abuild/0002-abuild-add-provides-information.patch29
-rw-r--r--main/abuild/APKBUILD9
3 files changed, 68 insertions, 2 deletions
diff --git a/main/abuild/0001-abuild-use-scanelf-soname-to-find-the-provides-so.patch b/main/abuild/0001-abuild-use-scanelf-soname-to-find-the-provides-so.patch
new file mode 100644
index 000000000..8fe9ce296
--- /dev/null
+++ b/main/abuild/0001-abuild-use-scanelf-soname-to-find-the-provides-so.patch
@@ -0,0 +1,32 @@
+From 87953c711587b932fb8e9f95798a0907faaaecf6 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 4 Sep 2012 12:30:08 +0000
+Subject: [PATCH 1/2] abuild: use scanelf --soname to find the provides-so
+
+---
+ abuild.in | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/abuild.in b/abuild.in
+index 32dd153..3acec46 100755
+--- a/abuild.in
++++ b/abuild.in
+@@ -778,8 +778,13 @@ prepare_tracedeps() {
+ [ "$arch" = "noarch" ] && return 0
+ options_has "!tracedeps" && return 0
+ # lets tell all the .so files this package provides in .provides-so
+- find -name '*.so' -o -name '*.so.[0-9]*' | sed 's:.*/::' \
+- >"$controldir"/.provides-so
++ scanelf --recursive --nobanner --soname "$dir" | while read etype soname file; do
++ # if soname field is missing, soname will be the filepath
++ # we only want shared libs
++ case $soname in
++ *.so|*.so.[0-9]*) echo ${soname##*/};;
++ esac
++ done >"$controldir"/.provides-so
+ # lets tell all the places we should look for .so files - all rpaths
+ scanelf -q -Rr "$dir" | sed -e 's/[[:space:]].*//' -e 's/:/\n/' \
+ | sort | uniq \
+--
+1.7.12
+
diff --git a/main/abuild/0002-abuild-add-provides-information.patch b/main/abuild/0002-abuild-add-provides-information.patch
new file mode 100644
index 000000000..a4ea86964
--- /dev/null
+++ b/main/abuild/0002-abuild-add-provides-information.patch
@@ -0,0 +1,29 @@
+From 76e93e602f74e0fcf8cfc708fd93b4f71b74781e Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 4 Sep 2012 13:37:26 +0000
+Subject: [PATCH 2/2] abuild: add provides information
+
+---
+ abuild.in | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/abuild.in b/abuild.in
+index 3acec46..207cc66 100755
+--- a/abuild.in
++++ b/abuild.in
+@@ -919,8 +919,11 @@ trace_apk_deps() {
+ fi
+ done
+
+- [ -z "$autodeps" ] && return 0
+ echo "# automatically detected:" >> "$dir"/.PKGINFO
++ if [ -f "$dir"/.provides-so ]; then
++ sed 's/^/provides = /' "$dir"/.provides-so >> "$dir"/.PKGINFO
++ fi
++ [ -z "$autodeps" ] && return 0
+ for i in $autodeps; do
+ echo "depend = $i" >> "$dir"/.PKGINFO
+ done
+--
+1.7.12
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index de3f37010..8f9c750ed 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,10 +2,13 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.12.1
-pkgrel=1
+pkgrel=2
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
0001-abuild-add-support-for-uncompressed-tar-archives.patch
+ 0001-abuild-use-scanelf-soname-to-find-the-provides-so.patch
+ 0002-abuild-add-provides-information.patch
+
"
depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1 uclibc-utils
abuildhelper curl"
@@ -49,4 +52,6 @@ cpan() {
}
md5sums="92348750a3354c3ec7b811716543b8e5 abuild-2.12.1.tar.bz2
-b04eb6325bf8014ea9fc974344f71a82 0001-abuild-add-support-for-uncompressed-tar-archives.patch"
+b04eb6325bf8014ea9fc974344f71a82 0001-abuild-add-support-for-uncompressed-tar-archives.patch
+8ba51a92d24d9e54bfdd1133bc2f0f8d 0001-abuild-use-scanelf-soname-to-find-the-provides-so.patch
+454e0c6a8a3ee97ec4b00874203f700c 0002-abuild-add-provides-information.patch"