summaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-05 10:03:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-05 10:04:02 +0000
commitca442115b5abce8104b35efa28280650b326c9f8 (patch)
tree47d22c694832a192c0d2b2fef9bbb3e63ef8accb /main/abuild
parentca97c182b8e6364f5048e520f59863340293ac55 (diff)
downloadaports-ca442115b5abce8104b35efa28280650b326c9f8.tar.bz2
aports-ca442115b5abce8104b35efa28280650b326c9f8.tar.xz
main/abuild: add version number to provides
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-add-version-number-to-provides.patch27
-rw-r--r--main/abuild/APKBUILD6
2 files changed, 31 insertions, 2 deletions
diff --git a/main/abuild/0001-abuild-add-version-number-to-provides.patch b/main/abuild/0001-abuild-add-version-number-to-provides.patch
new file mode 100644
index 000000000..32a50dbfe
--- /dev/null
+++ b/main/abuild/0001-abuild-add-version-number-to-provides.patch
@@ -0,0 +1,27 @@
+From 7ca99d75b3c810546fec0418662586e34be141cd Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 5 Sep 2012 08:10:13 +0000
+Subject: [PATCH] abuild: add version number to provides
+
+So it is not treated as a special 'virtual'
+We use version number 0 for now.
+---
+ abuild.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/abuild.in b/abuild.in
+index 207cc66..f4d724c 100755
+--- a/abuild.in
++++ b/abuild.in
+@@ -921,7 +921,7 @@ trace_apk_deps() {
+
+ echo "# automatically detected:" >> "$dir"/.PKGINFO
+ if [ -f "$dir"/.provides-so ]; then
+- sed 's/^/provides = /' "$dir"/.provides-so >> "$dir"/.PKGINFO
++ sed 's/^\(.*\)/provides = \1=0/' "$dir"/.provides-so >> "$dir"/.PKGINFO
+ fi
+ [ -z "$autodeps" ] && return 0
+ for i in $autodeps; do
+--
+1.7.12
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 8f9c750ed..7ea7adf2e 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,12 +2,13 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.12.1
-pkgrel=2
+pkgrel=3
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
0001-abuild-add-support-for-uncompressed-tar-archives.patch
0001-abuild-use-scanelf-soname-to-find-the-provides-so.patch
0002-abuild-add-provides-information.patch
+ 0001-abuild-add-version-number-to-provides.patch
"
depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1 uclibc-utils
@@ -54,4 +55,5 @@ cpan() {
md5sums="92348750a3354c3ec7b811716543b8e5 abuild-2.12.1.tar.bz2
b04eb6325bf8014ea9fc974344f71a82 0001-abuild-add-support-for-uncompressed-tar-archives.patch
8ba51a92d24d9e54bfdd1133bc2f0f8d 0001-abuild-use-scanelf-soname-to-find-the-provides-so.patch
-454e0c6a8a3ee97ec4b00874203f700c 0002-abuild-add-provides-information.patch"
+454e0c6a8a3ee97ec4b00874203f700c 0002-abuild-add-provides-information.patch
+e8e910f86ed1892bd46facb88164a27b 0001-abuild-add-version-number-to-provides.patch"