summaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-14 06:13:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-14 06:13:54 +0000
commitfa0b37908ede74b37439becd35227d5107958137 (patch)
tree9b15b853d3e2be1b9e1c7a63d2bc2108698de662 /main/abuild
parent1134d93cc3bfca6e2e2780605fd581d611f8d7a6 (diff)
downloadaports-fa0b37908ede74b37439becd35227d5107958137.tar.bz2
aports-fa0b37908ede74b37439becd35227d5107958137.tar.xz
main/abuild: include patch for ldpath-recursive support
needed by openjdk6
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/APKBUILD4
-rw-r--r--main/abuild/abuild-git.patch14
2 files changed, 11 insertions, 7 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index d708a500c..d0b581047 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.12.1
-pkgrel=7
+pkgrel=8
url=http://git.alpinelinux.org/cgit/abuild/
depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1 uclibc-utils
abuildhelper curl"
@@ -48,4 +48,4 @@ cpan() {
}
md5sums="92348750a3354c3ec7b811716543b8e5 abuild-2.12.1.tar.bz2
-ed9600723681dbcb48fb62bfa19c3ca9 abuild-git.patch"
+90018b9a6e428de018cdd7ff868ebf85 abuild-git.patch"
diff --git a/main/abuild/abuild-git.patch b/main/abuild/abuild-git.patch
index 187d3c4dc..264952ac2 100644
--- a/main/abuild/abuild-git.patch
+++ b/main/abuild/abuild-git.patch
@@ -1,5 +1,5 @@
diff --git a/abuild.in b/abuild.in
-index 2780d2e..b86a941 100755
+index 2780d2e..b2e0197 100755
--- a/abuild.in
+++ b/abuild.in
@@ -404,6 +404,9 @@ default_unpack() {
@@ -64,7 +64,7 @@ index 2780d2e..b86a941 100755
found=${j%/.provides-so}
found=${found##*/.control.}
break
-@@ -911,26 +911,109 @@ trace_apk_deps() {
+@@ -911,26 +911,113 @@ trace_apk_deps() {
fi
done
@@ -103,15 +103,19 @@ index 2780d2e..b86a941 100755
+
+scan_shared_objects() {
+ local name="$1" controldir="$2" datadir="$3"
++ local opt=
+
+ # allow spaces in paths
+ IFS=:
+ set -- $(find_scanelf_paths "$datadir")
+ unset IFS
+
++ if options_has "ldpath-recursive"; then
++ opt="--recursive"
++ fi
+ msg "Scanning shared objects"
+ # lets tell all the .so files this package provides in .provides-so
-+ scanelf --nobanner --soname "$@" | while read etype soname file; do
++ scanelf --nobanner --soname $opt "$@" | while read etype soname file; do
+ # if soname field is missing, soname will be the filepath
+ sover=0
+ if [ -z "$file" ]; then
@@ -182,7 +186,7 @@ index 2780d2e..b86a941 100755
(
cd "$datadir"
# data.tar.gz
-@@ -941,6 +1024,7 @@ create_apks() {
+@@ -941,6 +1028,7 @@ create_apks() {
fi
tar -c "$@" | abuild-tar --hash | gzip -9 >"$dir"/data.tar.gz
@@ -190,7 +194,7 @@ index 2780d2e..b86a941 100755
# append the hash for data.tar.gz
local sha256=$(sha256sum "$dir"/data.tar.gz | cut -f1 -d' ')
echo "datahash = $sha256" >> "$dir"/.PKGINFO
-@@ -951,10 +1035,12 @@ create_apks() {
+@@ -951,10 +1039,12 @@ create_apks() {
| gzip -9 > control.tar.gz
abuild-sign -q control.tar.gz || exit 1