summaryrefslogtreecommitdiffstats
path: root/main/acf-alpine-baselayout
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-02-21 10:13:48 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-02-21 10:13:48 -0600
commit84cd971c827bfefb8343741c59a7f5355d821ce3 (patch)
tree4e89da9d8a8abf0264fa9a3163c7b18de451de11 /main/acf-alpine-baselayout
parent36568de1992e5a58ee66a40bd27b6fe7f01a7284 (diff)
downloadaports-84cd971c827bfefb8343741c59a7f5355d821ce3.tar.bz2
aports-84cd971c827bfefb8343741c59a7f5355d821ce3.tar.xz
main/acf-alpine-baselayout: compatibility with busybox 1.18 in health model
Diffstat (limited to 'main/acf-alpine-baselayout')
-rw-r--r--main/acf-alpine-baselayout/APKBUILD11
-rw-r--r--main/acf-alpine-baselayout/busybox-1.18-compat.patch27
2 files changed, 36 insertions, 2 deletions
diff --git a/main/acf-alpine-baselayout/APKBUILD b/main/acf-alpine-baselayout/APKBUILD
index 3a602f8c0..b42ef8f86 100644
--- a/main/acf-alpine-baselayout/APKBUILD
+++ b/main/acf-alpine-baselayout/APKBUILD
@@ -2,16 +2,23 @@
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-alpine-baselayout
pkgver=0.7.3
-pkgrel=2
+pkgrel=3
pkgdesc="A web-based system administration interface for alpine-baselayout"
url="http://git.alpinelinux.org/cgit/acf-alpine-baselayout"
arch="noarch"
license="GPL-2"
depends="acf-core lua lua-json4 lua-posix"
-source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2"
+source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2
+ busybox-1.18-compat.patch"
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < "$srcdir"/busybox-1.18-compat.patch
+}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
+
md5sums="b462fa1ff228f3552c2eea2d0a4fed96 acf-alpine-baselayout-0.7.3.tar.bz2"
diff --git a/main/acf-alpine-baselayout/busybox-1.18-compat.patch b/main/acf-alpine-baselayout/busybox-1.18-compat.patch
new file mode 100644
index 000000000..419531fb4
--- /dev/null
+++ b/main/acf-alpine-baselayout/busybox-1.18-compat.patch
@@ -0,0 +1,27 @@
+From 96aa7d8650f4de9f1d009e10d45df01d5e7a1331 Mon Sep 17 00:00:00 2001
+From: William Pitcock <nenolod@dereferenced.org>
+Date: Mon, 21 Feb 2011 10:11:48 -0600
+Subject: [PATCH] health model: work with procps and busybox 1.18
+
+---
+ health-model.lua | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/health-model.lua b/health-model.lua
+index 2749e2a..bb70073 100644
+--- a/health-model.lua
++++ b/health-model.lua
+@@ -49,8 +49,8 @@ get_system = function (self)
+ system.version = cfe({ value=indexver or fs.read_file("/etc/alpine-release") or "Unknown", label="Version" })
+ system.timezone = cfe({ value=date.what_tz(), label="Time Zone" })
+ system.uname = cfe({ value=querycmd("uname -a"), label="UName" })
+- system.memory = cfe({ value=querycmd("free"), label="Memory usage" })
+- system.memory.used = getpercentage(querycmd("free"), "Total:", 3, 4)
++ system.memory = cfe({ value=querycmd("free -o"), label="Memory usage" })
++ system.memory.used = getpercentage(querycmd("free -o"), "Total:", 3, 4)
+ return cfe({ type="group", value=system })
+ end
+
+--
+1.7.4.1
+