summaryrefslogtreecommitdiffstats
path: root/main/altermime
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-25 13:27:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-25 13:27:18 +0000
commit75a2431d8bfd9b3a351cd27531866894ee77645d (patch)
tree0afef984b416f84f88bdf088e6d06eb6696d37c9 /main/altermime
parent8ba68ea372576bbd961cba2eee5e726c2f97ba46 (diff)
downloadaports-75a2431d8bfd9b3a351cd27531866894ee77645d.tar.bz2
aports-75a2431d8bfd9b3a351cd27531866894ee77645d.tar.xz
main/altermime: moved from testing
Diffstat (limited to 'main/altermime')
-rw-r--r--main/altermime/APKBUILD39
-rw-r--r--main/altermime/makefile-flags.patch21
2 files changed, 60 insertions, 0 deletions
diff --git a/main/altermime/APKBUILD b/main/altermime/APKBUILD
new file mode 100644
index 000000000..1e4667716
--- /dev/null
+++ b/main/altermime/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=altermime
+pkgver=0.3.10
+pkgrel=0
+pkgdesc="program alter mime-encoded mailpacks"
+url="http://www.pldaniels.com/altermime/"
+arch="all"
+license="Sendmail"
+depends=
+makedepends=
+install=
+subpackages=
+source="http://www.pldaniels.com/altermime/altermime-$pkgver.tar.gz
+ makefile-flags.patch"
+
+_builddir="$srcdir"/altermime-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 altermime "$pkgdir"/usr/bin/altermime
+}
+
+md5sums="aaf0ad8029958a2dc6da3abb4dc178c2 altermime-0.3.10.tar.gz
+604775894fa4f8ddd9d44761ce2be2ea makefile-flags.patch"
diff --git a/main/altermime/makefile-flags.patch b/main/altermime/makefile-flags.patch
new file mode 100644
index 000000000..71a399051
--- /dev/null
+++ b/main/altermime/makefile-flags.patch
@@ -0,0 +1,21 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -9,7 +9,8 @@
+ # opposite of a disclaimer.
+ #ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS?=-Wall -Werror -g -I. -O2
++CFLAGS+=$(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
+@@ -19,7 +20,7 @@
+ all: altermime
+
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} altermime.c ${OBJS} ${LDFLAGS} -o altermime
+
+
+ # Build Install