summaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-01-27 16:21:47 +0200
committerTimo Teräs <timo.teras@iki.fi>2011-01-27 16:22:07 +0200
commit13842ccfaa717e729a345ace864c8121fa7697a7 (patch)
tree0fea9abff01e28bc4dcaa2936f2b3b5210d2f15b /main/apk-tools
parent8ccfff342c43a790a4faebe4b0e39230023757a6 (diff)
downloadaports-13842ccfaa717e729a345ace864c8121fa7697a7.tar.bz2
aports-13842ccfaa717e729a345ace864c8121fa7697a7.tar.xz
main/apk-tools: fix package caching
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/0001-db-fix-package-caching.patch28
-rw-r--r--main/apk-tools/APKBUILD6
2 files changed, 32 insertions, 2 deletions
diff --git a/main/apk-tools/0001-db-fix-package-caching.patch b/main/apk-tools/0001-db-fix-package-caching.patch
new file mode 100644
index 000000000..e4173c7db
--- /dev/null
+++ b/main/apk-tools/0001-db-fix-package-caching.patch
@@ -0,0 +1,28 @@
+From 1c6ab67984b20b49ed12a0576e59cd446a44ae84 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 21 Jan 2011 09:37:19 +0200
+Subject: [PATCH] db: fix package caching
+
+---
+ src/database.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/database.c b/src/database.c
+index c985233..53a18c7 100644
+--- a/src/database.c
++++ b/src/database.c
+@@ -2061,9 +2061,9 @@ static int apk_db_unpack_pkg(struct apk_database *db,
+
+ if (need_copy) {
+ if (r == 0)
+- renameat(db->cachetmp_fd, file, db->cache_fd, file);
++ renameat(db->cachetmp_fd, item, db->cache_fd, item);
+ else
+- unlinkat(db->cachetmp_fd, file, 0);
++ unlinkat(db->cachetmp_fd, item, 0);
+ }
+
+ if (r != 0) {
+--
+1.7.1
+
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index fcb46815c..322a660f8 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.0.7
-pkgrel=4
+pkgrel=5
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
@@ -9,6 +9,7 @@ makedepends="zlib-dev openssl-dev pkgconfig"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
0001-info-return-error-if-owning-package-was-not-found.patch
0001-gunzip-fix-ordering-of-boundary-callbacks.patch
+ 0001-db-fix-package-caching.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
@@ -52,4 +53,5 @@ static() {
md5sums="3c4591c594f9b2261ab588446a50d183 apk-tools-2.0.7.tar.bz2
1364d38e784ad6cc04e157665903ef0c 0001-info-return-error-if-owning-package-was-not-found.patch
-e47a96010eafab0b24588a7f6bb2800b 0001-gunzip-fix-ordering-of-boundary-callbacks.patch"
+e47a96010eafab0b24588a7f6bb2800b 0001-gunzip-fix-ordering-of-boundary-callbacks.patch
+dab65917565e998a345847f2b61f3f43 0001-db-fix-package-caching.patch"