summaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-17 07:16:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-17 07:17:52 +0000
commit3882d7fb0dc347b5f9880b48fcd1b47175cc4260 (patch)
treec9d1a7912760ad05240045daf172f039f8d24d3e /main/apk-tools
parent39c6b57e4674fd37f819d93bf8e4184f055ed598 (diff)
downloadaports-3882d7fb0dc347b5f9880b48fcd1b47175cc4260.tar.bz2
aports-3882d7fb0dc347b5f9880b48fcd1b47175cc4260.tar.xz
main/apk-tools: upgrade to 2.3.2
ref #1241
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/0001-db-strip-leading-and-trailing-slashes-from-protected.patch30
-rw-r--r--main/apk-tools/0002-audit-apply-protected_paths.d-masks-to-individual-fi.patch56
-rw-r--r--main/apk-tools/0003-ver-print-when-package-is-not-available-in-any-repo.patch41
-rw-r--r--main/apk-tools/0004-ver-make-quiet-output-suitable-for-scripting-piping.patch37
-rw-r--r--main/apk-tools/0005-ver-show-all-packages-with-v.patch26
-rw-r--r--main/apk-tools/APKBUILD16
6 files changed, 3 insertions, 203 deletions
diff --git a/main/apk-tools/0001-db-strip-leading-and-trailing-slashes-from-protected.patch b/main/apk-tools/0001-db-strip-leading-and-trailing-slashes-from-protected.patch
deleted file mode 100644
index aeb3926c9..000000000
--- a/main/apk-tools/0001-db-strip-leading-and-trailing-slashes-from-protected.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 38c1e65afbb334af0107c6bdd5362303473d866f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Tue, 1 May 2012 14:30:06 +0300
-Subject: [PATCH 1/5] db: strip leading and trailing slashes from protected
- path spec
-
----
- src/database.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/src/database.c b/src/database.c
-index 26774be..bcc707f 100644
---- a/src/database.c
-+++ b/src/database.c
-@@ -1181,6 +1181,12 @@ static int add_protected_path(void *ctx, apk_blob_t blob)
- break;
- }
-
-+ /* skip leading and trailing path separators */
-+ while (blob.len && blob.ptr[0] == '/')
-+ blob.ptr++, blob.len--;
-+ while (blob.len && blob.ptr[blob.len-1] == '/')
-+ blob.len--;
-+
- *apk_protected_path_array_add(&db->protected_paths) = (struct apk_protected_path) {
- .relative_pattern = apk_blob_cstr(blob),
- .protected = protected,
---
-1.7.10
-
diff --git a/main/apk-tools/0002-audit-apply-protected_paths.d-masks-to-individual-fi.patch b/main/apk-tools/0002-audit-apply-protected_paths.d-masks-to-individual-fi.patch
deleted file mode 100644
index 1e855baff..000000000
--- a/main/apk-tools/0002-audit-apply-protected_paths.d-masks-to-individual-fi.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From c9a43a14697fa955f31e495a8b03a523975ad285 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Tue, 1 May 2012 15:40:31 +0300
-Subject: [PATCH 2/5] audit: apply protected_paths.d masks to individual files
-
----
- src/audit.c | 21 ++++++++++++++++++---
- 1 file changed, 18 insertions(+), 3 deletions(-)
-
-diff --git a/src/audit.c b/src/audit.c
-index 071ff4d..03f977b 100644
---- a/src/audit.c
-+++ b/src/audit.c
-@@ -14,6 +14,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <dirent.h>
-+#include <fnmatch.h>
- #include <sys/stat.h>
- #include "apk_applet.h"
- #include "apk_database.h"
-@@ -199,14 +200,28 @@ recurse_check:
- atctx->pathlen--;
- } else {
- struct apk_db_file *dbf;
-+ struct apk_protected_path_array *ppaths = dbd->protected_paths;
-+ int i, protected = dbd->protected, symlinks_only = dbd->symlinks_only;
-+
-+ /* inherit file's protection mask */
-+ for (i = 0; i < ppaths->num; i++) {
-+ struct apk_protected_path *ppath = &ppaths->item[i];
-+ char *slash = strchr(ppath->relative_pattern, '/');
-+ if (slash == NULL) {
-+ if (fnmatch(ppath->relative_pattern, name, FNM_PATHNAME) != 0)
-+ continue;
-+ protected = ppath->protected;
-+ symlinks_only = ppath->symlinks_only;
-+ }
-+ }
-
- if (actx->mode == MODE_BACKUP) {
-- if (!dbd->protected)
-+ if (!protected)
- goto done;
-- if (dbd->symlinks_only && !S_ISLNK(fi.mode))
-+ if (symlinks_only && !S_ISLNK(fi.mode))
- goto done;
- } else {
-- if (dbd->protected)
-+ if (protected)
- goto done;
- }
-
---
-1.7.10
-
diff --git a/main/apk-tools/0003-ver-print-when-package-is-not-available-in-any-repo.patch b/main/apk-tools/0003-ver-print-when-package-is-not-available-in-any-repo.patch
deleted file mode 100644
index 6d589c61a..000000000
--- a/main/apk-tools/0003-ver-print-when-package-is-not-available-in-any-repo.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 9154b8b5e44859ce0a1fd0ba292b26bf8dc8d046 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon, 7 May 2012 08:51:02 +0200
-Subject: [PATCH 3/5] ver: print '?' when package is not available in any repo
-
-This makes it possible to differ between downgradable packages (-l '<')
-and unavailable in repos (-l '?').
----
- src/apk_version.h | 1 +
- src/ver.c | 3 ++-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/apk_version.h b/src/apk_version.h
-index dcbf20f..4275343 100644
---- a/src/apk_version.h
-+++ b/src/apk_version.h
-@@ -14,6 +14,7 @@
-
- #include "apk_blob.h"
-
-+#define APK_VERSION_UNKNOWN 0
- #define APK_VERSION_EQUAL 1
- #define APK_VERSION_LESS 2
- #define APK_VERSION_GREATER 4
-diff --git a/src/ver.c b/src/ver.c
-index 4bfd607..90b6cd6 100644
---- a/src/ver.c
-+++ b/src/ver.c
-@@ -125,7 +125,8 @@ static void ver_print_package_status(struct ver_ctx *ictx, struct apk_database *
- break;
- }
- }
-- r = apk_version_compare_blob(*pkg->version, *latest);
-+ r = latest->len ? apk_version_compare_blob(*pkg->version, *latest)
-+ : APK_VERSION_UNKNOWN;
- opstr = apk_version_op_string(r);
- if ((ictx->limchars != NULL) && (strchr(ictx->limchars, *opstr) == NULL))
- return;
---
-1.7.10
-
diff --git a/main/apk-tools/0004-ver-make-quiet-output-suitable-for-scripting-piping.patch b/main/apk-tools/0004-ver-make-quiet-output-suitable-for-scripting-piping.patch
deleted file mode 100644
index 36eb225cd..000000000
--- a/main/apk-tools/0004-ver-make-quiet-output-suitable-for-scripting-piping.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 08595072ae2156a399253d34b41748da99e84bfc Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon, 7 May 2012 08:54:41 +0200
-Subject: [PATCH 4/5] ver: make --quiet output suitable for scripting/piping
-
-Do not print version numbers or compare result char when in quiet
-mode. This makes the output suitable for be used in scripts or pipes.
-
-For example:
-
- # Upgrade all packages that matches a given regexp
- apk version --limit '<' --quiet | grep $regexp | apk fix --reinstall
-
- # Delete all packages that are removed from repository
- apk version --limit '?' --quiet | xargs apk del
----
- src/ver.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/ver.c b/src/ver.c
-index 90b6cd6..05ffce9 100644
---- a/src/ver.c
-+++ b/src/ver.c
-@@ -130,6 +130,10 @@ static void ver_print_package_status(struct ver_ctx *ictx, struct apk_database *
- opstr = apk_version_op_string(r);
- if ((ictx->limchars != NULL) && (strchr(ictx->limchars, *opstr) == NULL))
- return;
-+ if (apk_verbosity <= 0) {
-+ printf("%s\n", pkg->name->name);
-+ return;
-+ }
- snprintf(pkgname, sizeof(pkgname), PKG_VER_FMT,
- PKG_VER_PRINTF(pkg));
- printf("%-40s%s " BLOB_FMT, pkgname, opstr, BLOB_PRINTF(*latest));
---
-1.7.10
-
diff --git a/main/apk-tools/0005-ver-show-all-packages-with-v.patch b/main/apk-tools/0005-ver-show-all-packages-with-v.patch
deleted file mode 100644
index dee3e5a45..000000000
--- a/main/apk-tools/0005-ver-show-all-packages-with-v.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From a6b28beef055c9c454fba49d02995765e6f3aeab Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon, 7 May 2012 10:53:45 +0200
-Subject: [PATCH 5/5] ver: show all packages with -v
-
-ref #1122
----
- src/ver.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/ver.c b/src/ver.c
-index 05ffce9..c20547a 100644
---- a/src/ver.c
-+++ b/src/ver.c
-@@ -161,7 +161,7 @@ static int ver_main(void *ctx, struct apk_database *db, int argc, char **argv)
- if (ictx->limchars) {
- if (strlen(ictx->limchars) == 0)
- ictx->limchars = NULL;
-- } else if (argc == 0) {
-+ } else if (argc == 0 && apk_verbosity == 1) {
- ictx->limchars = "<";
- }
-
---
-1.7.10
-
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index e28da1b81..ab1ff34ad 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,17 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.3.1
-pkgrel=2
+pkgver=2.3.2
+pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static lua-apk:luaapk"
depends=
makedepends="zlib-dev openssl-dev lua-dev"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
- 0001-db-strip-leading-and-trailing-slashes-from-protected.patch
- 0002-audit-apply-protected_paths.d-masks-to-individual-fi.patch
- 0003-ver-print-when-package-is-not-available-in-any-repo.patch
- 0004-ver-make-quiet-output-suitable-for-scripting-piping.patch
- 0005-ver-show-all-packages-with-v.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
@@ -63,9 +58,4 @@ luaapk() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib/
}
-md5sums="e343935cc2680a42f3da0f442045f046 apk-tools-2.3.1.tar.bz2
-e88cc45d942821dc7f222f1f4c1e6292 0001-db-strip-leading-and-trailing-slashes-from-protected.patch
-ad846965eb7826818d27c083fda6cc60 0002-audit-apply-protected_paths.d-masks-to-individual-fi.patch
-e4f00e434f66770cb28bbd4b1e97eb40 0003-ver-print-when-package-is-not-available-in-any-repo.patch
-3474af2f6db2794a4a2075a9d9b5af64 0004-ver-make-quiet-output-suitable-for-scripting-piping.patch
-be6b5f7298d625876ae0f4ae3a117d7c 0005-ver-show-all-packages-with-v.patch"
+md5sums="813b7c9fd7f6159972dc4fa5dfcc97c5 apk-tools-2.3.2.tar.bz2"