summaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-01-17 15:58:16 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-01-17 15:58:29 +0200
commit4546ec4b1aa5562ea7e21511bb31c610cf2d9f76 (patch)
treeb7679731e3efbfe734909fb9c19270e98f4b76d6 /main/apk-tools
parent0c5d885357a0c9be9336a6153aeb5a4c694ac5eb (diff)
downloadaports-4546ec4b1aa5562ea7e21511bb31c610cf2d9f76.tar.bz2
aports-4546ec4b1aa5562ea7e21511bb31c610cf2d9f76.tar.xz
main/apk-tools: upgrade to 2.2.3
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/APKBUILD6
-rw-r--r--main/apk-tools/fix-lua-apk.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 7f8b79912..86845e8e4 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.2.2
+pkgver=2.2.3
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static lua-apk:luaapk"
depends=
makedepends="zlib-dev openssl-dev lua-dev"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ fix-lua-apk.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
@@ -54,4 +55,5 @@ luaapk() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib/
}
-md5sums="1660ba53d447d2151371715d1225fdbf apk-tools-2.2.2.tar.bz2"
+md5sums="31dcb57491d08ea69f0d041aad94e865 apk-tools-2.2.3.tar.bz2
+66e110316e76408f19f8c44e698c26cb fix-lua-apk.patch"
diff --git a/main/apk-tools/fix-lua-apk.patch b/main/apk-tools/fix-lua-apk.patch
new file mode 100644
index 000000000..0c13e815b
--- /dev/null
+++ b/main/apk-tools/fix-lua-apk.patch
@@ -0,0 +1,13 @@
+diff --git a/src/lua-apk.c b/src/lua-apk.c
+index 6fbd1cf..45488c2 100644
+--- a/src/lua-apk.c
++++ b/src/lua-apk.c
+@@ -208,7 +208,7 @@ static int Papk_exists(lua_State *L)
+ apk_blob_t blob = APK_BLOB_STR(depstr);
+ apk_blob_pull_dep(&blob, db, &dep);
+
+- if (APK_BLOB_IS_NULL(blob) || b.len > 0)
++ if (APK_BLOB_IS_NULL(blob) || blob.len > 0)
+ goto ret_nil;
+
+ name = dep.name;