summaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-24 14:36:02 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-24 14:36:02 +0200
commite63b456471b99a1e5f4fe01ad71ddf1bdc3c11a3 (patch)
tree15c7b079d49334e56f7891b9edc1fd73157504b5 /main/apk-tools
parent66e807f5ef864ef72b7b5825d879241ae6fb4160 (diff)
downloadaports-e63b456471b99a1e5f4fe01ad71ddf1bdc3c11a3.tar.bz2
aports-e63b456471b99a1e5f4fe01ad71ddf1bdc3c11a3.tar.xz
main/apk-tools: fix audit --backup --recurse
Needs be upstreamed.
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/APKBUILD9
-rw-r--r--main/apk-tools/audit-recurse.patch20
2 files changed, 26 insertions, 3 deletions
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index e25ae86d7..ab9326161 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,14 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static lua-apk:luaapk"
depends=
makedepends="zlib-dev openssl-dev lua-dev"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
0001-info-fix-exit-code-for-e.patch
- 0002-solver-fix-installation-of-non-repository-packages.patch"
+ 0002-solver-fix-installation-of-non-repository-packages.patch
+ audit-recurse.patch
+ "
url="http://git.alpinelinux.org/cgit/apk-tools/"
arch="all"
@@ -57,4 +59,5 @@ luaapk() {
md5sums="f87882b3ddad44282459ee40b143ad1a apk-tools-2.3.0.tar.bz2
eab1caf0fa9a889605efcb5b147e594d 0001-info-fix-exit-code-for-e.patch
-a8d15a4a1ce915695735d897a2227c2b 0002-solver-fix-installation-of-non-repository-packages.patch"
+a8d15a4a1ce915695735d897a2227c2b 0002-solver-fix-installation-of-non-repository-packages.patch
+99503e540fa223ee2b6c54b9b84d2571 audit-recurse.patch"
diff --git a/main/apk-tools/audit-recurse.patch b/main/apk-tools/audit-recurse.patch
new file mode 100644
index 000000000..a7675531c
--- /dev/null
+++ b/main/apk-tools/audit-recurse.patch
@@ -0,0 +1,20 @@
+diff --git a/src/database.c b/src/database.c
+index ae6810b..26774be 100644
+--- a/src/database.c
++++ b/src/database.c
+@@ -353,7 +353,6 @@ struct apk_db_dir *apk_db_dir_get(struct apk_database *db, apk_blob_t name)
+ .protected = ppath->protected,
+ .symlinks_only = ppath->symlinks_only,
+ };
+- dir->has_protected_children |= ppath->protected;
+ } else {
+ if (fnmatch(ppath->relative_pattern, relative_name, FNM_PATHNAME) != 0)
+ continue;
+@@ -361,6 +360,7 @@ struct apk_db_dir *apk_db_dir_get(struct apk_database *db, apk_blob_t name)
+ dir->protected = ppath->protected;
+ dir->symlinks_only = ppath->symlinks_only;
+ }
++ dir->has_protected_children |= ppath->protected;
+ }
+
+ return dir;