summaryrefslogtreecommitdiffstats
path: root/main/asterisk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-30 12:12:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-30 12:12:51 +0000
commitdb85e2d3773a748e6b74090d3e482e9001949ce0 (patch)
tree2149d3ff1b37407895ded179de828f0ea8fdce4d /main/asterisk
parent2810f5b0c13ddc9697be7af31248a15f733f4b2f (diff)
downloadaports-db85e2d3773a748e6b74090d3e482e9001949ce0.tar.bz2
aports-db85e2d3773a748e6b74090d3e482e9001949ce0.tar.xz
main/asterisk: enable chan_mobile
Add it to a subpackage called asterisk-mobile fixes #1178
Diffstat (limited to 'main/asterisk')
-rw-r--r--main/asterisk/APKBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index 9df345ecc..bebc30f7c 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
pkgver=10.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="Asterisk: A Module Open Source PBX System"
pkgusers="asterisk"
pkggroups="asterisk"
@@ -13,11 +13,12 @@ depends=
makedepends="autoconf automake libtool ncurses-dev popt-dev newt-dev zlib-dev
postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev tar
freetds-dev openssl-dev lua-dev alsa-lib-dev spandsp-dev tiff-dev
- libresample sqlite-dev wget speex-dev libogg-dev"
+ libresample sqlite-dev wget speex-dev libogg-dev bluez-dev"
install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-doc $pkgname-pgsql $pkgname-odbc
$pkgname-tds $pkgname-fax $pkgname-sample-config:sample
- $pkgname-sounds-moh:sound_moh $pkgname-sounds-en:sound_en"
+ $pkgname-sounds-moh:sound_moh $pkgname-sounds-en:sound_en
+ $pkgname-mobile"
source="http://downloads.asterisk.org/pub/telephony/asterisk/releases/asterisk-${pkgver/_/-}.tar.gz
100-uclibc-daemon.patch
101-caps-uclibc.patch
@@ -64,11 +65,14 @@ build() {
--with-asound \
--without-x11 \
--with-spandsp \
+ --with-bluetooth \
|| return 1
# and figure out which modules to build
rm menuselect.makeopts
make menuselect.makeopts
+ # enable chan_mobile
+ sed -i -e '/^MENUSELECT_ADDONS=/s/chan_mobile//' menuselect.makeopts
make ASTCFLAGS="$CFLAGS" ASTLDFLAGS="$LDFLAGS" || return 1
}
@@ -142,6 +146,12 @@ fax() {
_find_and_move '*_fax*'
}
+mobile() {
+ depends=
+ install=
+ _find_and_move '*_mobile*'
+}
+
sample() {
arch="noarch"
pkgdesc="Sample configuration files for asterisk"